summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-02-05 07:02:49 +0100
committerJeroen Roovers <jer@gentoo.org>2016-02-05 07:02:49 +0100
commit259225a5e7ea0daefd13ff1e7be27aac052bd227 (patch)
treebbe761095005e2cd04ffce72fb16694aa56ff894 /net-misc
parentdev-libs/nettle: Stable for HPPA (bug #573646). (diff)
downloadgentoo-259225a5e7ea0daefd13ff1e7be27aac052bd227.tar.gz
gentoo-259225a5e7ea0daefd13ff1e7be27aac052bd227.tar.bz2
gentoo-259225a5e7ea0daefd13ff1e7be27aac052bd227.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.02.01.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index a1b3d52fc182..fb7e44ca474b 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -3,3 +3,4 @@ DIST youtube-dl-2016.01.15.tar.gz 1898595 SHA256 c1e22ca3286aff74a668d1f8ef5c84c
DIST youtube-dl-2016.01.23.tar.gz 1916234 SHA256 449f4330fac38ed9f2bb2a547f42c1cfd705bab6a8839ff279fc4bd91f233154 SHA512 ca3a7f2024ae97a290869e123d4b67c858f35894ce4309c295c3994c9bac1f406152cd36d893cd48c79bd3ada92b6e5e76ac1a87cbffc321fe03efc131d0445f WHIRLPOOL 9c628d0fd5f3abe1d44dd84a50400e837eb61d597a120d17b3e353430a250becea91bbdfa575b821e6f849092494640d4eac0b3917731c459202d324d00cb522
DIST youtube-dl-2016.01.27.tar.gz 1918307 SHA256 d06bb62ea19aef3ebb842ac01d98bbeee378e06d9e7c7a2f3bef343205b52ee9 SHA512 a6f38466c5d5c369c487913703348fa04c2272af6cbc300be552eaed5f1e713c0083f6f569dae3fd01a77f30582e36629c90bcd0dfe5641ffded04626c67cc6a WHIRLPOOL fb753cf67fd1142837e78dfbde9e4c14cfc41a499b15b36024647a7eb78763938edf6c9a88c2cd05951071d4e2d66e28fa704188b5b6c553be4bfde243773dfd
DIST youtube-dl-2016.01.29.tar.gz 1919314 SHA256 4b39800787d288c5f44cf00342d900d53386ef41c66a5397b406acac9fd60212 SHA512 24f7646bd81040e16cbe66b5c67c35800799fef797b735c45e3f3c13cc5222c390484c452eedba2a42ba57dc3a88a153d7430bf0db378f6619191af1dfcfa4e8 WHIRLPOOL 975cf0c68ed2149513157e5e7107d66ca7355f97a2e6e8773282df071b28413e19d099a07b241a43fe2d6f5a703ea4dc12567db2c63e110775a35b8e9f5aae78
+DIST youtube-dl-2016.02.01.tar.gz 1931170 SHA256 cac97ffda989b5783b7b05dd04cdb9f602089163d4c0dbeb55fc749899422613 SHA512 04db834328056402b2a91e9e244fa74abb4a7782fcea489c9ae7b6669f96ebc2d13cff576b02ccbbdfe3d6914c90ebc2b728334422a0ae0e454b1e03dd9db2b1 WHIRLPOOL 04c731813b50770864504f13b18cf493639975a27de0e10faad20e90f8d800228e4792924c5a7ca1b0e99df5729422e9a6209253159af63f5ab07e8118c87af2
diff --git a/net-misc/youtube-dl/youtube-dl-2016.02.01.ebuild b/net-misc/youtube-dl/youtube-dl-2016.02.01.ebuild
new file mode 100644
index 000000000000..5db7401e49ee
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.02.01.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink chaturbate drtuber eporner eroprofile
+ extremetube fourtube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies mofosex motherless porn91 pornhd pornotube
+ pornovoisines pornoxo redtube sexykarma sexu sunporno slutload
+ spankbang spankwire thisav trutube tube8 vporn xbef xnxx xtube
+ xvideos xxxymovies youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ youtube_dl/extractor/tumblr.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc README.txt
+ doman ${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}