summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 22:20:42 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:23 +0100
commit271ceef6e3b68f800e65618724e3bfac404e3206 (patch)
tree428f1601d8e280d89e22df67cbc630baca527035 /net-misc
parentnet-misc/etherdfs: drop 20180203-r1 (diff)
downloadgentoo-271ceef6e3b68f800e65618724e3bfac404e3206.tar.gz
gentoo-271ceef6e3b68f800e65618724e3bfac404e3206.tar.bz2
gentoo-271ceef6e3b68f800e65618724e3bfac404e3206.zip
net-misc/ethflop: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ethflop/ethflop-20191003-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/ethflop/ethflop-20191003-r1.ebuild b/net-misc/ethflop/ethflop-20191003-r1.ebuild
new file mode 100644
index 000000000000..4c959d92f65d
--- /dev/null
+++ b/net-misc/ethflop/ethflop-20191003-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="A network-backed floppy emulator for DOS"
+HOMEPAGE="http://ethflop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+S="${WORKDIR}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="tsr"
+
+BDEPEND="
+ app-arch/unzip
+ tsr? ( dev-lang/nasm )
+"
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+src_compile() {
+ tc-export CC
+ default
+
+ use tsr && emake tsr
+}
+
+src_install() {
+ dobin ethflopd
+
+ if use tsr; then
+ insinto /usr/share/ethflop
+ doins ethflop.com
+ fi
+
+ newinitd "${FILESDIR}"/ethflopd.initd ethflopd
+ newconfd "${FILESDIR}"/ethflopd.confd ethflopd
+ systemd_dounit "${FILESDIR}"/ethflopd.service
+
+ dodoc ethflop.txt
+}