summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-17 08:31:56 +0000
committerSam James <sam@gentoo.org>2020-10-17 08:32:05 +0000
commit2759ca74611a5aebdc14a873670a26f66a899107 (patch)
tree2ef1a1e73ad53bb35aa8db4454fa4eecb981d740 /net-misc
parentnet-misc/unison: bump to 2.48.15_p4 (diff)
downloadgentoo-2759ca74611a5aebdc14a873670a26f66a899107.tar.gz
gentoo-2759ca74611a5aebdc14a873670a26f66a899107.tar.bz2
gentoo-2759ca74611a5aebdc14a873670a26f66a899107.zip
net-misc/unison: bump to 2.51.3_rc2
Bug: https://bugs.gentoo.org/709646 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/unison/Manifest1
-rw-r--r--net-misc/unison/unison-2.51.3_rc2.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/net-misc/unison/Manifest b/net-misc/unison/Manifest
index 100bc6830fcf..bf2621848790 100644
--- a/net-misc/unison/Manifest
+++ b/net-misc/unison/Manifest
@@ -5,3 +5,4 @@ DIST unison-2.48.4.tar.gz 1200861 BLAKE2B 8e262e3e28b9f4cbe3925340aa3b08e99f1c30
DIST unison-2.51.2-manual.html 311981 BLAKE2B 1e1bc18d5bca5d50976b28c4e59cc27fcc1ef4415514c6a8db4be02659c168949738cf2941f88cb949097c16e455bd3fb50aee0fdc6023d3d36d6821f74acd05 SHA512 2fc47e51ffde2e9176ca85d4d29fe0d254b539112d867782e9bb0f71ea74ad02892a88b6bfe59756268875f0d62abfb125406e4939671a0eb8a64696ba01b997
DIST unison-2.51.2-manual.pdf 518963 BLAKE2B 30d0010e7a11b10bb9fba3f5836e084452429f09a94cfcc639305d17ea69499eeeac1026a0bd35c785b08456d79b1b4c68c348c10237509c8cf4e45720d037e0 SHA512 170b280e5a9ad0fc4ed848aaa1c4a6a8977edfdcc133bf3288c03e1d4d6d20383cfa06593b9d149e746795945f6afb8d807cfa16f5cf8ab47795e3074776518d
DIST unison-2.51.2.tar.gz 691251 BLAKE2B 39f72e7229826ec1a2151b7d7af416d85ffe2f9e6f1277be77d2202088d41fa3aca45413b931e661d72b787710f7d3429352542554990bb638589d52f77fe43f SHA512 9ba24f8d46f3f8bf3c26ea1beb396e276a82a742d9e8479cb421ff9f97fa2051fc8fb809b5f47ebc88dcb6a04878e1bdeae8081540e35af710ccbdaead84c115
+DIST unison-2.51.3_rc2.tar.gz 1370090 BLAKE2B dd4657000a771a22f8e61af25d34334872595c53fa24d863e67f52fd0accd3406ac61fff61d01b1977ae3d6f2eaa50aedb2b31dd47abc6d08bd3d240786dab8b SHA512 0acadad426370305093854953f7fc1a720a2be67a4d8327a54822bb94c7292136cc7d7980fb80291125a2f0280180443913bfd49c428ed5a27e3537ef4713153
diff --git a/net-misc/unison/unison-2.51.3_rc2.ebuild b/net-misc/unison/unison-2.51.3_rc2.ebuild
new file mode 100644
index 000000000000..8b53a7db107c
--- /dev/null
+++ b/net-misc/unison/unison-2.51.3_rc2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="https://www.seas.upenn.edu/~bcpierce/unison/"
+SRC_URI="https://github.com/bcpierce00/unison/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+# Not available for the rcs
+#SRC_URI+=" doc? (
+# https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.pdf
+# https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html
+# )"
+
+LICENSE="GPL-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="gtk doc static debug threads +ocamlopt test"
+RESTRICT="!ocamlopt? ( strip ) !test? ( test )"
+
+# ocaml version so we are sure it has ocamlopt use flag
+DEPEND="gtk? ( dev-ml/lablgtk:2= )"
+RDEPEND="
+ ${DEPEND}
+ || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen )
+ >=app-eselect/eselect-unison-0.4
+"
+
+DOCS=( BUGS.txt CONTRIB INSTALL NEWS README ROADMAP.txt TODO.txt )
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ myconf="$myconf THREADS=true"
+ fi
+
+ if use static; then
+ myconf="$myconf STATIC=true"
+ fi
+
+ if use debug; then
+ myconf="$myconf DEBUGGING=true"
+ fi
+
+ if use gtk; then
+ myconf="$myconf UISTYLE=gtk2"
+ else
+ myconf="$myconf UISTYLE=text"
+ fi
+
+ use ocamlopt || myconf="$myconf NATIVE=false"
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake $myconf CFLAGS=""
+}
+
+src_test() {
+ emake test CFLAGS=""
+}
+
+src_install() {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ local binname
+ cd src || die
+ for binname in unison unison-fsmonitor; do
+ newbin ${binname} ${binname}-${SLOT}
+ done
+ if use doc; then
+ DOCS+=( "${DISTDIR}/${P}-manual.pdf" )
+ HTML_DOCS=( "${DISTDIR}/${P}-manual.html" )
+ fi
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
+ elog "in your profile files to access exactly this version over ssh."
+ elog "Or you can use 'eselect unison' to set the version."
+ eselect unison update
+}