summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-02-17 09:00:35 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-02-17 09:00:37 -0500
commit407001141120d270fa156a83c9e691c34e7489f4 (patch)
treea6a0aa7d5602f7c703627e987e5c1019d9cbefd1 /net-misc
parentjava-utils-2.eclass: use find with -path instead of -wholename (diff)
downloadgentoo-407001141120d270fa156a83c9e691c34e7489f4.tar.gz
gentoo-407001141120d270fa156a83c9e691c34e7489f4.tar.bz2
gentoo-407001141120d270fa156a83c9e691c34e7489f4.zip
net-misc/yt-dlp: add 2023.2.17
Straight to stable given previous is broken for youtube. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2023.2.17.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 2c9992f2f9a3..d37b98608d42 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1 +1,2 @@
DIST yt-dlp-2023.1.6.tar.gz 2529382 BLAKE2B d7682346f6a783e0e7b95fc312bb0fffc2b1053ecdbf9b61b01402a8b6d73e41ca7809876d99a1e29d0bf708443444908e931715197c8c2c42807672a55eae61 SHA512 6817659dfa90bc9eecd60608e995097af381d598b4c094784b0cb467f16794f60ffcd90db89444cff2d86312ab1310f13c438def9fb05e3a2154c2e88af48670
+DIST yt-dlp-2023.2.17.tar.gz 2571278 BLAKE2B 74d077f5798e3371c42b5eb76e676619e7650a4003875d08995302c55120af7aa966a1e422cba6b0655cad4dedeed1874c2eb2348242fba9b0df12544d4dcfb3 SHA512 2458358410acb49ffc8fd4c49abddc78a5015ccf48979350fc5f9d4805c2dd8f7b728837ad30d55119cf8fc6842cba36a995ef9291da22af3135ae4a9077a5ba
diff --git a/net-misc/yt-dlp/yt-dlp-2023.2.17.ebuild b/net-misc/yt-dlp/yt-dlp-2023.2.17.ebuild
new file mode 100644
index 000000000000..60931d0bd7a5
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2023.2.17.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+inherit bash-completion-r1 distutils-r1 optfeature pypi wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 ~riscv x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust requires for pycryptodome and optional dependencies (bug #828466)
+ sed -ri requirements.txt \
+ -e "s/^(pycryptodome)x/\1/" \
+ -e "/^(brotli.*|certifi|mutagen|websockets)/d" || die
+}
+
+python_test() {
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}