summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-04-08 22:20:02 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-04-10 20:34:37 +0200
commit40e381fbafa49f66abc7e869f188ae613f88324e (patch)
treea4ea4342305d477ee41d7fa748d0b5c413156ba9 /net-misc
parentacct-user/gopher: User for gofish (diff)
downloadgentoo-40e381fbafa49f66abc7e869f188ae613f88324e.tar.gz
gentoo-40e381fbafa49f66abc7e869f188ae613f88324e.tar.bz2
gentoo-40e381fbafa49f66abc7e869f188ae613f88324e.zip
net-misc/gofish: Tidy up ebuild
* Correct LICENSE field * Reorder members Closes: https://github.com/gentoo/gentoo/pull/20309 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gofish/gofish-1.2.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/net-misc/gofish/gofish-1.2.ebuild b/net-misc/gofish/gofish-1.2.ebuild
index 6f64429d30ae..6ab8823d84a2 100644
--- a/net-misc/gofish/gofish-1.2.ebuild
+++ b/net-misc/gofish/gofish-1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,16 +8,11 @@ inherit user
DESCRIPTION="Gofish gopher server"
HOMEPAGE="http://gofish.sourceforge.net"
SRC_URI="mirror://sourceforge/gofish/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S=${WORKDIR}/${PN}
pkg_setup() {
enewgroup gopher
@@ -25,9 +20,12 @@ pkg_setup() {
}
src_configure() {
- econf \
- --localstatedir=/var \
+ local myeconfargs=(
+ --localstatedir=/var
--disable-mmap-cache
+ )
+
+ econf "${myeconfargs[@]}"
}
src_install() {