summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Arnold <nerdboy@gentoo.org>2020-08-09 12:15:21 -0700
committerStephen Arnold <nerdboy@gentoo.org>2020-08-09 12:15:21 -0700
commit4ad773667769976017f40ad88c556c50a7a42158 (patch)
tree3532a58f5303732bfadc8edf3431f369d6692f44 /net-misc
parentapp-misc/screenie: Maintainer retired (diff)
downloadgentoo-4ad773667769976017f40ad88c556c50a7a42158.tar.gz
gentoo-4ad773667769976017f40ad88c556c50a7a42158.tar.bz2
gentoo-4ad773667769976017f40ad88c556c50a7a42158.zip
net-misc/stunnel: update r1 init script, add ~arm64 to 5.56-r1
* adds --exec to stop args and einfo for symlink Closes: https://bugs.gentoo.org/736332 Package-Manager: Portage-2.3.67, Repoman-2.3.17 Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/stunnel/files/stunnel-r15
-rw-r--r--net-misc/stunnel/stunnel-5.56-r1.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/net-misc/stunnel/files/stunnel-r1 b/net-misc/stunnel/files/stunnel-r1
index a73527ed57e7..11530eabe720 100644
--- a/net-misc/stunnel/files/stunnel-r1
+++ b/net-misc/stunnel/files/stunnel-r1
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
extra_started_commands="reload"
@@ -38,7 +38,8 @@ start() {
stop() {
get_config || return 1
ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --quiet --pidfile ${PIDFILE}
+ start-stop-daemon --stop --quiet --exec /usr/bin/stunnel \
+ --pidfile ${PIDFILE}
eend $? "Failed to stop ${SVCNAME}"
}
diff --git a/net-misc/stunnel/stunnel-5.56-r1.ebuild b/net-misc/stunnel/stunnel-5.56-r1.ebuild
index 10f5581fa01a..a6540f0fb4ad 100644
--- a/net-misc/stunnel/stunnel-5.56-r1.ebuild
+++ b/net-misc/stunnel/stunnel-5.56-r1.ebuild
@@ -17,7 +17,7 @@ SRC_URI="ftp://ftp.stunnel.org/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="ipv6 selinux stunnel3 tcpd"
DEPEND="dev-libs/openssl:0=
@@ -85,5 +85,7 @@ pkg_postinst() {
einfo "If you want to run multiple instances of stunnel, create a new config"
einfo "file ending with .conf in /etc/stunnel/. **Make sure** you change "
- einfo "\'pid= \' with a unique filename."
+ einfo "\'pid= \' with a unique filename. For openrc make a symlink from the"
+ einfo "stunnel init script to \'stunnel.name\' and use that to start|stop"
+ einfo "your custom instance"
}