summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-11-26 09:54:04 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-11-26 09:59:34 +0100
commit5616d3b3c78fee3e7ba879eed5c606e05339bc50 (patch)
tree30ccb6ee044dd80a0c371e04cfdcc34c171462ce /net-misc
parentdev-lang/spidermonkey: remove mandatory clang requirement from 102 (diff)
downloadgentoo-5616d3b3c78fee3e7ba879eed5c606e05339bc50.tar.gz
gentoo-5616d3b3c78fee3e7ba879eed5c606e05339bc50.tar.bz2
gentoo-5616d3b3c78fee3e7ba879eed5c606e05339bc50.zip
net-misc/rsync: fix rrsync.1 man page handling
Thanks to ionen for co-debugging the root cause of this. Closes: https://bugs.gentoo.org/883049 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rsync/rsync-3.2.7-r1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/net-misc/rsync/rsync-3.2.7-r1.ebuild b/net-misc/rsync/rsync-3.2.7-r1.ebuild
index bbb1e1b44e26..6c31cf7b857f 100644
--- a/net-misc/rsync/rsync-3.2.7-r1.ebuild
+++ b/net-misc/rsync/rsync-3.2.7-r1.ebuild
@@ -96,6 +96,13 @@ src_prepare() {
if use examples || use rrsync; then
python_fix_shebang support/
fi
+
+ if [[ -f rrsync.1 ]]; then
+ # If the pre-build rrsync.1 man page exists, then link to it
+ # from support/rrsync.1 to avoid rsync's build system attempting
+ # re-creating the man page (bug #883049).
+ ln -s ../rrsync.1 support/rrsync.1 || die
+ fi
}
src_configure() {