summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Staroszczyk <piotr.staroszczyk@get24.org>2018-03-17 15:15:05 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-24 13:07:07 +0100
commit62aaf5e2e730f3df7c1fc127523fdac4ada7979a (patch)
tree399644a11870a2a429786c1ad92b13f4dce6e6b6 /net-misc
parentsys-kernel/dracut-crypt-ssh: bump to fix RDEPEND (diff)
downloadgentoo-62aaf5e2e730f3df7c1fc127523fdac4ada7979a.tar.gz
gentoo-62aaf5e2e730f3df7c1fc127523fdac4ada7979a.tar.bz2
gentoo-62aaf5e2e730f3df7c1fc127523fdac4ada7979a.zip
net-misc/streamlink: bump version to 0.11.0
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/streamlink/Manifest1
-rw-r--r--net-misc/streamlink/streamlink-0.11.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index a78c3f03f989..2881b97031aa 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1,4 +1,5 @@
DIST streamlink-0.1.0.tar.gz 960622 BLAKE2B 8d035784fc3585c738135a901b6da35b9acee2cc993e4b99b0ed609e6d68eefd6df5fff5ae4b63ef2267fd0606b2f5e29b56da4d40cf49a41c433ab58570a561 SHA512 78b5bd9d35c2fc9c1d9fe3954b439e56cfee48f2b73a95a2c08a53c3a66143938ba162f2d2ba29c8af989565c920756cab605ae772d73828a3dd5a41fc6d30c2
+DIST streamlink-0.11.0.tar.gz 30718822 BLAKE2B cbda2783bed0e7d721dad44ca8815fa862531fdff84007245a76205dd869098d9ef2d371035e784e1d002497bbbcf8268aa4ee94c63fdc0f16082cf55d878b8f SHA512 a62e906f7b37c9cd33ce5e7d5d84bfee9fa8ca5ddd4699e4985ed932147a346188026fd868b30e6b26ce6b5806217f838bbf8191074f9b0271dd87aaee501f7f
DIST streamlink-0.4.0.tar.gz 30674625 BLAKE2B 301ff7e2086425604c59d12063cd5b14f789dc39249bba96faedb0fece663f9e5d65f1f696d40f92f07a95a9edd5c915c71d22dcd1afb378cc000bac6eeebd5e SHA512 58a4110b1e6b20f0b05842ee8450a93d646d523a284cf60ad878b460b8e80081d78658f5abb67744609cfdd0a88ebbf97faf6453b2b53709f259e4f9cc093eed
DIST streamlink-0.6.0.tar.gz 30696706 BLAKE2B d735c9605b1d0bb9aa6c52c145b1ee3d9645d5a1be0ab0bbc4a84a3e9c5b527a8a35f3d61c2bc5e51d1549f6328802e13ca83231c08bebc90496144fb25c7dfe SHA512 b9f75bfd2cab577688ed84a6c690f776b2e3af38fa60edb7f2fd73f2c25246c81098652180c3adae61eec8798a7805988cad01c366989a961efdb1e12578af49
DIST streamlink-0.7.0.tar.gz 30709251 BLAKE2B 215a8aa8b273e9b46fb86020dd53cb15bd19cb3de77e0b6e4a124916b964077a012cec5358d81707782834031490921fcae8a3a8321b70a43a4b538321eac06e SHA512 6e908229295c4d129d2bb9bfc26c76b20d45c2c9dc8193528a259c572cddd4ea620f9f903fb639ddad206bcad05a416ccc50328d01489a7684ec724a8cf1c3c1
diff --git a/net-misc/streamlink/streamlink-0.11.0.ebuild b/net-misc/streamlink/streamlink-0.11.0.ebuild
new file mode 100644
index 000000000000..6096587d059d
--- /dev/null
+++ b/net-misc/streamlink/streamlink-0.11.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ dev-python/backports-shutil_which[$(python_gen_usedep 'python2*')]
+ $(python_gen_cond_dep 'dev-python/backports-shutil_get_terminal_size[${PYTHON_USEDEP}]' 'python2*')
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ media-video/rtmpdump
+ virtual/ffmpeg"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ )
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
+ ${RDEPEND}
+ )"
+
+python_configure_all() {
+ # Avoid iso-639, iso3166 dependencies since we use pycountry.
+ export STREAMLINK_USE_PYCOUNTRY=1
+}
+
+python_compile_all() {
+ use doc && emake -C docs html man
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use doc; then
+ local HTML_DOCS=( docs/_build/html/. )
+ doman docs/_build/man/*
+ fi
+ distutils-r1_python_install_all
+}