summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 22:21:23 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:24 +0100
commit6a75b2d1b1245905fb4042745dbd1907b43aa34e (patch)
treeffa5574910a844db33b4bc8a6d90a54525820120 /net-misc
parentnet-misc/ethflop: drop 20191003 (diff)
downloadgentoo-6a75b2d1b1245905fb4042745dbd1907b43aa34e.tar.gz
gentoo-6a75b2d1b1245905fb4042745dbd1907b43aa34e.tar.bz2
gentoo-6a75b2d1b1245905fb4042745dbd1907b43aa34e.zip
net-misc/igmpproxy: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/igmpproxy/igmpproxy-0.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/igmpproxy/igmpproxy-0.3-r1.ebuild b/net-misc/igmpproxy/igmpproxy-0.3-r1.ebuild
new file mode 100644
index 000000000000..cfbcbd34dfb9
--- /dev/null
+++ b/net-misc/igmpproxy/igmpproxy-0.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info systemd
+
+DESCRIPTION="A multicast routing daemon which uses IGMP forwarding"
+HOMEPAGE="https://github.com/pali/igmpproxy"
+SRC_URI="https://github.com/pali/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/igmpproxy.initd-r1 igmpproxy
+ systemd_dounit "${FILESDIR}"/"${PN}".service
+
+ newconfd "${FILESDIR}"/igmpproxy.confd igmpproxy
+}