summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-01-17 15:42:06 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-01-17 15:42:06 +0100
commit6f47443f187582756e6817bf73647c524823c4c2 (patch)
treedab0963b18497c95353aaf321a41d89e6820f445 /net-misc
parentmedia-gfx/argyllcms: 2.1.2 bump (diff)
downloadgentoo-6f47443f187582756e6817bf73647c524823c4c2.tar.gz
gentoo-6f47443f187582756e6817bf73647c524823c4c2.tar.bz2
gentoo-6f47443f187582756e6817bf73647c524823c4c2.zip
net-misc/rdesktop: backport an upstream segfault fix
This usually happens after "Retrying with plain RDP" message Closes: https://bugs.gentoo.org/705550 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rdesktop/files/rdesktop-1.9.0-rdssl_rkey_get_exp_mod.patch26
-rw-r--r--net-misc/rdesktop/rdesktop-1.9.0-r1.ebuild78
2 files changed, 104 insertions, 0 deletions
diff --git a/net-misc/rdesktop/files/rdesktop-1.9.0-rdssl_rkey_get_exp_mod.patch b/net-misc/rdesktop/files/rdesktop-1.9.0-rdssl_rkey_get_exp_mod.patch
new file mode 100644
index 000000000000..7ac0067da617
--- /dev/null
+++ b/net-misc/rdesktop/files/rdesktop-1.9.0-rdssl_rkey_get_exp_mod.patch
@@ -0,0 +1,26 @@
+From 53ba87dc174175e98332e22355ad8662c02880d6 Mon Sep 17 00:00:00 2001
+From: Markus Beth <markus.beth@zkrd.de>
+Date: Mon, 2 Dec 2019 11:22:13 +0100
+Subject: [PATCH] use correct modulus and exponent in rdssl_rkey_get_exp_mod
+
+---
+ ssl.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/ssl.c b/ssl.c
+index 930c7f94..0681a890 100644
+--- a/ssl.c
++++ b/ssl.c
+@@ -307,10 +307,10 @@ rdssl_rkey_get_exp_mod(RDSSL_RKEY * rkey, uint8 * exponent, uint32 max_exp_len,
+ {
+ size_t outlen;
+
+- outlen = (mpz_sizeinbase(modulus, 2) + 7) / 8;
++ outlen = (mpz_sizeinbase(rkey->n, 2) + 7) / 8;
+ if (outlen > max_mod_len)
+ return 1;
+- outlen = (mpz_sizeinbase(exponent, 2) + 7) / 8;
++ outlen = (mpz_sizeinbase(rkey->e, 2) + 7) / 8;
+ if (outlen > max_exp_len)
+ return 1;
+
diff --git a/net-misc/rdesktop/rdesktop-1.9.0-r1.ebuild b/net-misc/rdesktop/rdesktop-1.9.0-r1.ebuild
new file mode 100644
index 000000000000..1f8cd581a111
--- /dev/null
+++ b/net-misc/rdesktop/rdesktop-1.9.0-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools eutils
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="A Remote Desktop Protocol Client"
+HOMEPAGE="http://www.rdesktop.org/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="alsa ao ipv6 kerberos oss pcsc-lite pulseaudio xrandr"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+RDEPEND="
+ dev-libs/nettle:0=
+ >=net-libs/gnutls-3.2.0:0=
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ alsa? (
+ media-libs/alsa-lib
+ media-libs/libsamplerate
+ )
+ ao? (
+ >=media-libs/libao-0.8.6
+ media-libs/libsamplerate
+ )
+ kerberos? ( virtual/krb5 )
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.6.6 )
+ oss? ( media-libs/libsamplerate )
+ pulseaudio? (
+ media-libs/libsamplerate
+ media-sound/pulseaudio
+ )
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}
+ x11-libs/libXt"
+BDEPEND=virtual/pkgconfig
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.3-no_strip.patch
+ "${FILESDIR}"/${PN}-1.8.3-xrandr_configure.patch
+ "${FILESDIR}"/${P}-rdssl_rkey_get_exp_mod.patch
+)
+
+DOCS=( doc/ChangeLog doc/HACKING doc/TODO doc/keymapping.txt )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ if use pulseaudio; then
+ sound_conf="--with-sound=pulse"
+ elif use ao; then
+ sound_conf="--with-sound=libao"
+ elif use alsa; then
+ sound_conf="--with-sound=alsa"
+ else
+ sound_conf=$(use_with oss sound oss)
+ fi
+
+ econf \
+ $(use_with ipv6) \
+ $(use_with xrandr) \
+ $(use_enable kerberos credssp) \
+ $(use_enable pcsc-lite smartcard) \
+ ${sound_conf}
+}