summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-07-04 20:59:45 +0200
committerPacho Ramos <pacho@gentoo.org>2021-07-04 21:00:00 +0200
commit72782f1a78a8abb0f6c0c1dc29a6a7a4f1b56c1a (patch)
tree9d69ba6e823a1d59d1fe8a53a02f23a8b7103795 /net-misc
parentx11-libs/pango: Version bump to 1.48.7 (diff)
downloadgentoo-72782f1a78a8abb0f6c0c1dc29a6a7a4f1b56c1a.tar.gz
gentoo-72782f1a78a8abb0f6c0c1dc29a6a7a4f1b56c1a.tar.bz2
gentoo-72782f1a78a8abb0f6c0c1dc29a6a7a4f1b56c1a.zip
net-misc/r8168: Bump to 8.049.02
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/r8168/Manifest1
-rw-r--r--net-misc/r8168/r8168-8.049.02.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/r8168/Manifest b/net-misc/r8168/Manifest
index 44a50866fa5e..d780aca28ae1 100644
--- a/net-misc/r8168/Manifest
+++ b/net-misc/r8168/Manifest
@@ -1 +1,2 @@
DIST r8168-8.048.03.tar.bz2 109351 BLAKE2B f31ef24d42af737a97986f0e46bc6c737c43e8ccfe9fac8386eb9957a5d81620faa62602e1bec15840792785444b1d1bf8bafa2e5878c21f1962c7141d9bb32e SHA512 8da615a96cca413ca172e260c52c9f77a782e4feb466e4a4296ae11d895e9cc56bde0ed8634cc3a7a531a292072b68d19dcbe74d20ad9549266d3ee8e082096f
+DIST r8168-8.049.02.tar.bz2 113195 BLAKE2B ee34ac7249d732a867384fdd2c87321a513e7b2770c79d0c13666edca7d4bf752d853d7f91554d7ee716b3f30ec5f3a69aed96221a79a60282f0b6d2f70f05d6 SHA512 8ccb69ab533cde6ff88f0e8af2dd66f7e6ce9467020a727d47748c5109b64d6d14eee6bc151db5ddbe70a476a2def5f2faf3871902b335074f43dd05484d39e0
diff --git a/net-misc/r8168/r8168-8.049.02.ebuild b/net-misc/r8168/r8168-8.049.02.ebuild
new file mode 100644
index 000000000000..7a3513fe3b08
--- /dev/null
+++ b/net-misc/r8168/r8168-8.049.02.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info linux-mod
+
+DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
+HOMEPAGE="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software"
+
+# "GBE Ethernet LINUX driver r8168 for kernel up to 5.6" from above link,
+# we need to mirror it to avoid users from needing to fill a captcha to
+# download
+SRC_URI="https://dev.gentoo.org/~pacho/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+MODULE_NAMES="r8168(net:${S}/src)"
+BUILD_TARGETS="modules"
+
+CONFIG_CHECK="!R8169"
+ERROR_R8169="${P} requires Realtek 8169 PCI Gigabit Ethernet adapter (CONFIG_R8169) to be DISABLED"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+ einstalldocs
+}