summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-11-26 11:36:30 -0500
committerMike Gilbert <floppym@gentoo.org>2022-11-26 11:36:30 -0500
commit835f0179694d35eec8af5e167eaabfa789d686f7 (patch)
treef92b04ad0d7bc74140f335d77db58b8c54ed3582 /net-misc
parentdev-ruby/roadie: add 5.1.0 (diff)
downloadgentoo-835f0179694d35eec8af5e167eaabfa789d686f7.tar.gz
gentoo-835f0179694d35eec8af5e167eaabfa789d686f7.tar.bz2
gentoo-835f0179694d35eec8af5e167eaabfa789d686f7.zip
net-misc/rsync: sync live ebuild
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rsync/rsync-9999.ebuild32
1 files changed, 28 insertions, 4 deletions
diff --git a/net-misc/rsync/rsync-9999.ebuild b/net-misc/rsync/rsync-9999.ebuild
index 804909ae11e6..6c31cf7b857f 100644
--- a/net-misc/rsync/rsync-9999.ebuild
+++ b/net-misc/rsync/rsync-9999.ebuild
@@ -37,8 +37,9 @@ fi
LICENSE="GPL-3"
SLOT="0"
-IUSE="acl examples iconv lz4 ssl stunnel system-zlib xattr xxhash zstd"
+IUSE="acl examples iconv lz4 rrsync ssl stunnel system-zlib xattr xxhash zstd"
REQUIRED_USE+=" examples? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE+=" rrsync? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
>=dev-libs/popt-1.5
@@ -48,6 +49,12 @@ RDEPEND="
dev-lang/perl
)
lz4? ( app-arch/lz4:= )
+ rrsync? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/bracex[${PYTHON_USEDEP}]
+ ')
+ )
ssl? ( dev-libs/openssl:= )
system-zlib? ( sys-libs/zlib )
xattr? ( kernel_linux? ( sys-apps/attr ) )
@@ -55,7 +62,10 @@ RDEPEND="
zstd? ( >=app-arch/zstd-1.4:= )
iconv? ( virtual/libiconv )"
DEPEND="${RDEPEND}"
-BDEPEND="examples? ( ${PYTHON_DEPS} )"
+BDEPEND="
+ examples? ( ${PYTHON_DEPS} )
+ rrsync? ( ${PYTHON_DEPS} )
+"
if [[ ${PV} == *9999 ]] ; then
BDEPEND+=" ${PYTHON_DEPS}
@@ -69,7 +79,7 @@ fi
pkg_setup() {
# - USE=examples needs Python itself at runtime, but nothing else
# - 9999 needs commonmark at build time
- if [[ ${PV} == *9999 ]] || use examples ; then
+ if [[ ${PV} == *9999 ]] || use examples || use rrsync; then
python-single-r1_pkg_setup
fi
}
@@ -82,6 +92,17 @@ src_prepare() {
eautoconf -o configure.sh
eautoheader && touch config.h.in
fi
+
+ if use examples || use rrsync; then
+ python_fix_shebang support/
+ fi
+
+ if [[ -f rrsync.1 ]]; then
+ # If the pre-build rrsync.1 man page exists, then link to it
+ # from support/rrsync.1 to avoid rsync's build system attempting
+ # re-creating the man page (bug #883049).
+ ln -s ../rrsync.1 support/rrsync.1 || die
+ fi
}
src_configure() {
@@ -92,6 +113,7 @@ src_configure() {
$(use_enable acl acl-support)
$(use_enable iconv)
$(use_enable lz4)
+ $(use_with rrsync)
$(use_enable ssl openssl)
$(use_with !system-zlib included-zlib)
$(use_enable xattr xattr-support)
@@ -126,7 +148,9 @@ src_install() {
# Install the useful contrib scripts
if use examples ; then
- python_fix_shebang support/
+ # The 'rrsync' script is installed conditionally via the 'rrysnc'
+ # USE flag, and not via the 'examples' USE flag.
+ rm support/rrsync* || die
exeinto /usr/share/rsync
doexe support/*