summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-01-24 09:44:59 -0500
committerCraig Andrews <candrews@gentoo.org>2023-01-24 09:46:22 -0500
commit86fd39196f59f92bde2e89ea8b93ad7237a02441 (patch)
tree337fe84c969d2a23d3c2658cb2de1cbbf6df638f /net-misc
parentmail-client/roundcube: drop 1.5.0, 1.5.1, 1.5.3, 1.6_beta, 1.6_rc, 1.6.0 (diff)
downloadgentoo-86fd39196f59f92bde2e89ea8b93ad7237a02441.tar.gz
gentoo-86fd39196f59f92bde2e89ea8b93ad7237a02441.tar.bz2
gentoo-86fd39196f59f92bde2e89ea8b93ad7237a02441.zip
net-misc/mptcpd: add 0.12
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/mptcpd/Manifest1
-rw-r--r--net-misc/mptcpd/mptcpd-0.12.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-misc/mptcpd/Manifest b/net-misc/mptcpd/Manifest
index d43011bddb17..8c8ba5d29b4f 100644
--- a/net-misc/mptcpd/Manifest
+++ b/net-misc/mptcpd/Manifest
@@ -1,2 +1,3 @@
DIST mptcpd-0.10.tar.gz 671508 BLAKE2B de29050b5394b4011bf2bc25ce7ca33c42da8332e10d89c849047508886080e43e0e4f734e77437f8b0122336b47aa4f6442c07461e4552183cf10b08dfb6d81 SHA512 758dd9c84446abab7a26e6e7fa19fedb6ab4a8dbb8d6e2535f3eae5b9b423becaec9a18aea214498b424d110227af7eafb630b91b963eb5be2da0da936fd3a93
DIST mptcpd-0.11.tar.gz 685987 BLAKE2B 70fa9cdf24116fad62f2527edca2fc4076541db533ac046d170975c011efdce4fb5341289f2825df3a9233f63c2bbdd172d2ea758d00cd19d473b1d9eea40fb0 SHA512 93f06e828365fd50fce17f4e9305891b2a6ef5e6cd40bff40bbfb614db8d7ff728455dcb23a1a53e5cb059f4dd5ff7a5dcee2cfe8b4cedab1bffc32c87b0e400
+DIST mptcpd-0.12.tar.gz 690687 BLAKE2B 35c0b66268a04312f1d174348c40abc81d95f190860672740f4dd9ab472f1ecb4a6604b65a4ecf5084c9b98c1c1d50b3b0a7d5a714fa7e5568200a90909eb088 SHA512 313ce6f3905192fc614d419d498bfd814632730a50e3119039f076b4cec32360424f237a18cfec8c80a52ea6555a6e21949669ccb85e3178bd83748a2de66f73
diff --git a/net-misc/mptcpd/mptcpd-0.12.ebuild b/net-misc/mptcpd/mptcpd-0.12.ebuild
new file mode 100644
index 000000000000..e97f30754fdf
--- /dev/null
+++ b/net-misc/mptcpd/mptcpd-0.12.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info systemd
+
+DESCRIPTION="Daemon that performs multipath TCP path management related operations."
+HOMEPAGE="https://github.com/intel/mptcpd/"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="debug doc"
+
+RDEPEND="
+ >=dev-libs/ell-0.45.0
+ elibc_musl? ( sys-libs/argp-standalone )
+ "
+DEPEND="
+ ${RDEPEND}
+ >=sys-kernel/linux-headers-5.6
+ "
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ app-text/pandoc
+ )
+ virtual/pkgconfig
+ "
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/intel/mptcpd.git"
+else
+ SRC_URI="https://github.com/intel/mptcpd/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+CONFIG_CHECK="MPTCP"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9-no-werror.patch
+)
+
+src_prepare() {
+ default
+
+ # For Werror patch
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-kernel=upstream
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable debug)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+ use doc && emake doxygen-doc
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}