summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-17 18:00:47 +0100
committerSam James <sam@gentoo.org>2022-04-17 18:05:57 +0100
commit882b77edf896534ffd91d0fb17696bfda91e635b (patch)
tree64ce88293c7c25b0c3af7a1a77460257be8fad9a /net-misc
parentdev-util/strace: drop 5.12-r1, 5.14-r1, 5.16 (diff)
downloadgentoo-882b77edf896534ffd91d0fb17696bfda91e635b.tar.gz
gentoo-882b77edf896534ffd91d0fb17696bfda91e635b.tar.bz2
gentoo-882b77edf896534ffd91d0fb17696bfda91e635b.zip
net-misc/rsync: drop 3.2.3-r4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rsync/rsync-3.2.3-r4.ebuild122
1 files changed, 0 insertions, 122 deletions
diff --git a/net-misc/rsync/rsync-3.2.3-r4.ebuild b/net-misc/rsync/rsync-3.2.3-r4.ebuild
deleted file mode 100644
index 38c591855af9..000000000000
--- a/net-misc/rsync/rsync-3.2.3-r4.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} != 3.2.3 ]]; then
- # Make sure we revert the autotools hackery applied in 3.2.3.
- die "Please use rsync-9999.ebuild as a basis for version bumps"
-fi
-
-WANT_LIBTOOL=none
-
-inherit autotools prefix systemd
-
-DESCRIPTION="File transfer program to keep remote files into sync"
-HOMEPAGE="https://rsync.samba.org/"
-SRC_DIR="src"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SRC_URI="https://rsync.samba.org/ftp/rsync/${SRC_DIR}/${P/_/}.tar.gz"
-S="${WORKDIR}/${P/_/}"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="acl examples iconv ipv6 lz4 ssl stunnel system-zlib xattr xxhash zstd"
-
-RDEPEND="acl? ( virtual/acl )
- lz4? ( app-arch/lz4 )
- ssl? ( dev-libs/openssl:0= )
- system-zlib? ( sys-libs/zlib )
- xattr? ( kernel_linux? ( sys-apps/attr ) )
- xxhash? ( dev-libs/xxhash )
- zstd? ( >=app-arch/zstd-1.4 )
- >=dev-libs/popt-1.5
- iconv? ( virtual/libiconv )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}/rsync-3.2.3-glibc-lchmod.patch"
- "${FILESDIR}/rsync-3.2.3-cross.patch"
- )
- default
- eautoconf -o configure.sh
- touch config.h.in || die
-}
-
-src_configure() {
- local myeconfargs=(
- --with-rsyncd-conf="${EPREFIX}"/etc/rsyncd.conf
- --without-included-popt
- $(use_enable acl acl-support)
- $(use_enable iconv)
- $(use_enable ipv6)
- $(use_enable lz4)
- $(use_enable ssl openssl)
- $(use_with !system-zlib included-zlib)
- $(use_enable xattr xattr-support)
- $(use_enable xxhash)
- $(use_enable zstd)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- newconfd "${FILESDIR}"/rsyncd.conf.d rsyncd
- newinitd "${FILESDIR}"/rsyncd.init.d-r1 rsyncd
-
- dodoc NEWS.md README.md TODO tech_report.tex
-
- insinto /etc
- newins "${FILESDIR}"/rsyncd.conf-3.0.9-r1 rsyncd.conf
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/rsyncd.logrotate rsyncd
-
- insinto /etc/xinetd.d
- newins "${FILESDIR}"/rsyncd.xinetd-3.0.9-r1 rsyncd
-
- # Install stunnel helpers
- if use stunnel ; then
- emake DESTDIR="${D}" install-ssl-daemon
- fi
-
- # Install the useful contrib scripts
- if use examples ; then
- exeinto /usr/share/rsync
- doexe support/*
- rm -f "${ED}"/usr/share/rsync/{Makefile*,*.c}
- fi
-
- eprefixify "${ED}"/etc/{,xinetd.d}/rsyncd*
-
- systemd_newunit "packaging/systemd/rsync.service" "rsyncd.service"
-}
-
-pkg_postinst() {
- if grep -Eqis '^[[:space:]]use chroot[[:space:]]*=[[:space:]]*(no|0|false)' \
- "${EROOT}"/etc/rsyncd.conf "${EROOT}"/etc/rsync/rsyncd.conf ; then
- ewarn "You have disabled chroot support in your rsyncd.conf. This"
- ewarn "is a security risk which you should fix. Please check your"
- ewarn "/etc/rsyncd.conf file and fix the setting 'use chroot'."
- fi
- if use stunnel ; then
- einfo "Please install \">=net-misc/stunnel-4\" in order to use stunnel feature."
- einfo
- einfo "You maybe have to update the certificates configured in"
- einfo "${EROOT}/etc/stunnel/rsync.conf"
- fi
- if use system-zlib ; then
- ewarn "Using system-zlib is incompatible with <rsync-3.1.1 when"
- ewarn "using the --compress option."
- ewarn
- ewarn "When syncing with >=rsync-3.1.1 built with bundled zlib,"
- ewarn "and the --compress option, add --new-compress (-zz)."
- ewarn
- ewarn "For syncing the portage tree, add:"
- ewarn "PORTAGE_RSYNC_EXTRA_OPTS=\"--new-compress\" to make.conf"
- fi
-}