summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPPed72 <paolo.pedroni@iol.it>2022-02-07 18:03:28 +0100
committerSam James <sam@gentoo.org>2022-02-18 02:49:41 +0000
commit8de3857d393de4b24bc5044a5951d44c050e3c97 (patch)
treee45419d72aca2769ce93bb5e44dcb6d5755d1624 /net-misc
parentdev-cpp/notcurses: upgrade 3.0.0 -> 3.0.5 (diff)
downloadgentoo-8de3857d393de4b24bc5044a5951d44c050e3c97.tar.gz
gentoo-8de3857d393de4b24bc5044a5951d44c050e3c97.tar.bz2
gentoo-8de3857d393de4b24bc5044a5951d44c050e3c97.zip
net-misc/netkit-telnetd: Sync with Debian (new patches)
Bugfixes, new CMake-based buildsystem, EAPI=8 Closes: https://bugs.gentoo.org/832858 Signed-off-by: Paolo Pedroni <paolo.pedroni@iol.it> Package-Manager: Portage-3.0.30, Repoman-3.0.3 Closes: https://github.com/gentoo/gentoo/pull/24116 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/netkit-telnetd/Manifest1
-rw-r--r--net-misc/netkit-telnetd/files/netkit-telnetd-0.17-r13-gentooification.patch43
-rw-r--r--net-misc/netkit-telnetd/netkit-telnetd-0.17-r13.ebuild55
3 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/netkit-telnetd/Manifest b/net-misc/netkit-telnetd/Manifest
index 87eda0ebbdb9..25a5c9106043 100644
--- a/net-misc/netkit-telnetd/Manifest
+++ b/net-misc/netkit-telnetd/Manifest
@@ -1,2 +1,3 @@
DIST netkit-telnet-0.17.tar.gz 133749 BLAKE2B 0eef225adeb0dd332ffd9cce0285213e6aa89f04263fb37e3dac35462492732265b2c29bd2a86277e39e0ad55267ff1a150f1140823c91d44c29cf6a20df8e7e SHA512 e2cfabed12326af5e288def1821353eacffb4586008263dcd1bed1a9dd9d8548e51e68d7ede58ea75927783ba534ea8807ec722271843a77146f064f3d826dd3
DIST netkit-telnet_0.17-41.debian.tar.xz 36592 BLAKE2B 6db35c25e14b219c15c4dd180f0dab064e5b101b42f29e7b71d99f797d22a51b376e6de148cf83fa479039f0ecbc811ecc36953dd89ae11f079b4ed42690d18f SHA512 4de0d51c6cc3c9113b38c9ab76553d22294a02a86d2e02a0481bdad77887782902d41f99eb5dd268bee175ebee5489b3e9871012234a7480a431ef47015cdf5c
+DIST netkit-telnet_0.17-42.debian.tar.xz 36068 BLAKE2B 393460c0e7a688c2c200e039ef1f462ecef0eba842982c64563325966148ee659ad1a86a8beea16046d5c1513c426d295787dc75b67f11201cdb091ec523a62a SHA512 0fa374bb4d9feff3a4cc84f7a2a9dcdacfdd22e5da9bcf253199d2e886d01da2cf5034820915ffbf50362814c3ce65ab1b6518e35e01b07c43839810fa3f8459
diff --git a/net-misc/netkit-telnetd/files/netkit-telnetd-0.17-r13-gentooification.patch b/net-misc/netkit-telnetd/files/netkit-telnetd-0.17-r13-gentooification.patch
new file mode 100644
index 000000000000..3ca6b15a788a
--- /dev/null
+++ b/net-misc/netkit-telnetd/files/netkit-telnetd-0.17-r13-gentooification.patch
@@ -0,0 +1,43 @@
+diff -Naur a/telnetd/CMakeLists.txt b/telnetd/CMakeLists.txt
+--- a/telnetd/CMakeLists.txt 2022-02-07 17:37:04.831149960 +0100
++++ b/telnetd/CMakeLists.txt 2022-02-07 17:42:48.482998276 +0100
+@@ -6,11 +6,11 @@
+ -DNO_REVOKE \
+ -DKLUDGELINEMODE \
+ -DDIAGNOSTICS \
+- -DLOGIN_WRAPPER='\"/usr/lib/telnetlogin\"' \
++ -DLOGIN_WRAPPER='\"/usr/sbin/telnetlogin\"' \
+ ")
+
+ add_executable(
+- in.telnetd
++ telnetd
+ global.c
+ setproctitle.c
+ slc.c
+@@ -21,19 +21,22 @@
+ utility.c
+ )
+ target_link_libraries(
+- in.telnetd
++ telnetd
+ ncurses
+ util
+ )
+ install(
+- TARGETS in.telnetd
++ TARGETS telnetd
+ DESTINATION ${SBIN_DIR}
+ )
+
+ install(
+ FILES telnetd.8
+ DESTINATION ${MAN_DIR}/man8/
+- RENAME in.telnetd.8
++)
++install(
++ FILES issue.net.5
++ DESTINATION ${MAN_DIR}/man5/
+ )
+ install(
+ CODE "execute_process( \
diff --git a/net-misc/netkit-telnetd/netkit-telnetd-0.17-r13.ebuild b/net-misc/netkit-telnetd/netkit-telnetd-0.17-r13.ebuild
new file mode 100644
index 000000000000..7423dd55a7dc
--- /dev/null
+++ b/net-misc/netkit-telnetd/netkit-telnetd-0.17-r13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit cmake
+
+PATCHLEVEL=42
+DESCRIPTION="Standard Linux telnet client and server"
+#old HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+# This might be the best HOMEPAGE now?
+HOMEPAGE="https://launchpad.net/netkit-telnet"
+# http://packages.debian.org/stablesource/netkit-telnet
+# http://packages.debian.org/testing/source/netkit-telnet
+# No upstream mirror exists anymore?
+# old ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-telnet-${PV}.tar.gz
+SRC_URI="mirror://gentoo/netkit-telnet-${PV}.tar.gz
+ mirror://debian/pool/main/n/netkit-telnet/netkit-telnet_0.17-${PATCHLEVEL}.debian.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2:=
+ !net-misc/telnet-bsd"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/netkit-telnet-${PV}
+
+src_prepare() {
+ # Patch: [0]
+ # Gentoo used to lack a maintainer for this package.
+ # A security problem arose. While reviewing our options for how
+ # should we proceed with the security bug we decided it would be
+ # better to just stay in sync with debian's own netkit-telnet
+ # package. Lots of bug fixes by them over time which were not in
+ # our telnetd.
+ rm "${WORKDIR}/debian/patches/use-cmake-as-buildsystem-debian-extras.patch" || die
+ eapply "${WORKDIR}/debian/patches"
+ eapply "${FILESDIR}/netkit-telnetd-0.17-r13-gentooification.patch"
+
+ cmake_src_prepare
+}
+
+src_install() {
+ cmake_src_install
+
+ dosym telnetd /usr/sbin/in.telnetd
+ dodoc "${FILESDIR}/net.issue.sample"
+ newdoc telnet/README README.telnet
+ newdoc telnet/TODO TODO.telnet
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}/telnetd.xinetd" telnetd
+}