summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-11-06 10:27:32 +0100
committerJeroen Roovers <jer@gentoo.org>2016-11-06 10:32:22 +0100
commit97f8b8c6dbf5002dfbba5a4913aee7d55f0b4605 (patch)
tree3b880d5aaf85897af134d87dcc8c54931024a4a0 /net-misc
parentnet-misc/pps-tools: Old. (diff)
downloadgentoo-97f8b8c6dbf5002dfbba5a4913aee7d55f0b4605.tar.gz
gentoo-97f8b8c6dbf5002dfbba5a4913aee7d55f0b4605.tar.bz2
gentoo-97f8b8c6dbf5002dfbba5a4913aee7d55f0b4605.zip
net-misc/chrony: Drop USE=pps preference now that it has a dependency. Update live ebuild.
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/chrony/chrony-2.4-r1.ebuild7
-rw-r--r--net-misc/chrony/chrony-9999.ebuild26
2 files changed, 20 insertions, 13 deletions
diff --git a/net-misc/chrony/chrony-2.4-r1.ebuild b/net-misc/chrony/chrony-2.4-r1.ebuild
index c2601db3e7e5..954f2663a4ff 100644
--- a/net-misc/chrony/chrony-2.4-r1.ebuild
+++ b/net-misc/chrony/chrony-2.4-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils systemd toolchain-funcs
DESCRIPTION="NTP client and server programs"
@@ -12,7 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="caps +cmdmon html ipv6 libedit +ntp +phc +pps readline +refclock +rtc selinux +adns"
+IUSE="caps +cmdmon html ipv6 libedit +ntp +phc pps readline +refclock +rtc selinux +adns"
REQUIRED_USE="
?? ( libedit readline )
"
@@ -41,6 +41,8 @@ src_prepare() {
-e 's:/etc/chrony\.:/etc/chrony/chrony.:g' \
-e 's:/var/run:/run:g' \
conf.c doc/*.man.in examples/* || die
+
+ default
}
src_configure() {
@@ -89,7 +91,6 @@ src_configure() {
src_compile() {
emake all docs $(usex html '' 'ADOC=true')
-
}
src_install() {
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index 13709c01b0b1..b744729dbdd8 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils git-r3 systemd toolchain-funcs
DESCRIPTION="NTP client and server programs"
@@ -12,7 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="caps +cmdmon ipv6 libedit +ntp +phc +pps readline +refclock +rtc selinux +adns"
+IUSE="caps +cmdmon html ipv6 libedit +ntp +phc pps readline +refclock +rtc selinux +adns"
REQUIRED_USE="
?? ( libedit readline )
"
@@ -20,11 +20,12 @@ REQUIRED_USE="
CDEPEND="
caps? ( sys-libs/libcap )
libedit? ( dev-libs/libedit )
+ pps? ( net-misc/pps-tools )
readline? ( >=sys-libs/readline-4.1-r4:= )
"
DEPEND="
${CDEPEND}
- sys-apps/texinfo
+ html? ( dev-ruby/asciidoctor )
"
RDEPEND="
${CDEPEND}
@@ -39,7 +40,9 @@ src_prepare() {
sed -i \
-e 's:/etc/chrony\.:/etc/chrony/chrony.:g' \
-e 's:/var/run:/run:g' \
- conf.c chrony.texi.in examples/* || die
+ conf.c doc/*.man.in examples/* || die
+
+ default
}
src_configure() {
@@ -73,7 +76,6 @@ src_configure() {
${EXTRA_ECONF} \
--docdir=/usr/share/doc/${PF} \
--chronysockdir=/run/chrony \
- --infodir=/usr/share/info \
--mandir=/usr/share/man \
--prefix=/usr \
--sysconfdir=/etc/chrony \
@@ -88,26 +90,30 @@ src_configure() {
}
src_compile() {
- emake all docs
+ emake all docs $(usex html '' 'ADOC=true')
}
src_install() {
default
- doinfo chrony.info*
-
newinitd "${FILESDIR}"/chronyd.init-r1 chronyd
newconfd "${FILESDIR}"/chronyd.conf chronyd
insinto /etc/${PN}
newins examples/chrony.conf.example1 chrony.conf
+ docinto examples
dodoc examples/*.example*
+ if use html; then
+ docinto html
+ dodoc doc/*.html
+ fi
+
keepdir /var/{lib,log}/chrony
insinto /etc/logrotate.d
- newins "${FILESDIR}"/chrony-2.2.logrotate chrony
+ newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
systemd_newunit "${FILESDIR}"/chronyd.service-r2 chronyd.service
systemd_enable_ntpunit 50-chrony chronyd.service