summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 19:59:14 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 19:59:14 -0500
commit998cc7ffa86d8db40abcbbbdb7e62863c306a300 (patch)
tree656228f77e9e15ef87dc800f0d82513339c6595d /net-misc
parentnet-misc/udpxy: remove old version (diff)
downloadgentoo-998cc7ffa86d8db40abcbbbdb7e62863c306a300.tar.gz
gentoo-998cc7ffa86d8db40abcbbbdb7e62863c306a300.tar.bz2
gentoo-998cc7ffa86d8db40abcbbbdb7e62863c306a300.zip
net-misc/utelnetd: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/utelnetd/files/utelnetd.initd4
-rw-r--r--net-misc/utelnetd/utelnetd-0.1.11-r1.ebuild35
-rw-r--r--net-misc/utelnetd/utelnetd-0.1.9-r2.ebuild33
3 files changed, 70 insertions, 2 deletions
diff --git a/net-misc/utelnetd/files/utelnetd.initd b/net-misc/utelnetd/files/utelnetd.initd
index fe87e80f6798..3e84801be844 100644
--- a/net-misc/utelnetd/files/utelnetd.initd
+++ b/net-misc/utelnetd/files/utelnetd.initd
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-misc/utelnetd/utelnetd-0.1.11-r1.ebuild b/net-misc/utelnetd/utelnetd-0.1.11-r1.ebuild
new file mode 100644
index 000000000000..ad00d89bb2bf
--- /dev/null
+++ b/net-misc/utelnetd/utelnetd-0.1.11-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A small Telnet daemon, derived from the Axis tools"
+HOMEPAGE="http://www.pengutronix.de/software/utelnetd/index_en.html"
+SRC_URI="http://www.pengutronix.de/software/utelnetd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/shadow"
+
+src_prepare() {
+ sed -i \
+ -e "/(STRIP)/d" \
+ -e "/^CC/s:=.*:= $(tc-getCC):" \
+ -e "/fomit-frame-pointer/d" \
+ Makefile || die
+
+ default
+}
+
+src_install() {
+ dosbin utelnetd
+ dodoc ChangeLog README
+
+ newinitd "${FILESDIR}"/utelnetd.initd utelnetd
+}
diff --git a/net-misc/utelnetd/utelnetd-0.1.9-r2.ebuild b/net-misc/utelnetd/utelnetd-0.1.9-r2.ebuild
new file mode 100644
index 000000000000..1c55b5b9ea31
--- /dev/null
+++ b/net-misc/utelnetd/utelnetd-0.1.9-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A small Telnet daemon, derived from the Axis tools"
+HOMEPAGE="http://www.pengutronix.de/software/utelnetd_en.html"
+SRC_URI="http://www.pengutronix.de/software/utelnetd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/shadow"
+
+src_prepare() {
+ sed -i \
+ -e "/(STRIP)/d" \
+ -e "/^CC/s:=.*:= $(tc-getCC):" \
+ Makefile || die
+ default
+}
+
+src_install() {
+ dosbin utelnetd
+ dodoc ChangeLog README
+
+ newinitd "${FILESDIR}"/utelnetd.initd utelnetd
+}