summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-17 06:16:26 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-17 07:21:15 +0100
commita54778b6aabec9a840192367a05459341a29cd8a (patch)
tree3aea9fafde4c68b42f2bcd070598e00edc995e02 /net-misc
parentapp-admin/awscli: Bump to 1.27.73 (diff)
downloadgentoo-a54778b6aabec9a840192367a05459341a29cd8a.tar.gz
gentoo-a54778b6aabec9a840192367a05459341a29cd8a.tar.bz2
gentoo-a54778b6aabec9a840192367a05459341a29cd8a.zip
net-misc/miniupnpd: Bump to 2.3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/miniupnpd/Manifest2
-rw-r--r--net-misc/miniupnpd/miniupnpd-2.3.3.ebuild108
2 files changed, 110 insertions, 0 deletions
diff --git a/net-misc/miniupnpd/Manifest b/net-misc/miniupnpd/Manifest
index 7878ec3ab5ec..a52bbc3e8d9b 100644
--- a/net-misc/miniupnpd/Manifest
+++ b/net-misc/miniupnpd/Manifest
@@ -2,3 +2,5 @@ DIST miniupnpd-2.3.1.tar.gz 258050 BLAKE2B c11e3ecb3f1c6b97dfa1acfbc5f844f0bbdae
DIST miniupnpd-2.3.1.tar.gz.sig 543 BLAKE2B 7211174bf1fa2244fafa1df63c3f872a8c557845840fa83f7cdc6264f6692fa5b4919d8c086e78253451497d55fca22300894a8d0e0bde58dbf8baaa6d8e4a26 SHA512 c661f8e028f0a3d96cc943dacd85414570473cd6805c2215531d14f355da2cee3695083807c91218eabbb9d40efed3c8f1c0178cff9461bf92202b4a948088c7
DIST miniupnpd-2.3.2.tar.gz 259686 BLAKE2B fe451773be25fd7f5941f89b35a4c94f0bebd5ece93d3b3c526c3c0e1c436773a2c403eb407cde397565ef4ec8f50441a64890bb89a56a9006a6c4556e707cef SHA512 f0956b8f2e52fc9257f6512d780d17c920f6635afaeee604056f3b2afccbfda3f5e65d95d16f1d883bd9e7f4e372856cae620fabcf79c7c87e3f56bbcc089acc
DIST miniupnpd-2.3.2.tar.gz.sig 543 BLAKE2B 8c571eb454f6f31757b699c8a06e0b5ade575e058356aad7cdf727caf8f7a6563e98dde31d242cb1fadf136cf2c7bebbc32483c154f2538c1414f04299f40e38 SHA512 2a90aef1c1ca6210ddf5e29d75b0b0dc5daca949732b54a9bcd8230ecd8a4c3d5175b6561a68e180caa70547bcbd533994cad08c21630dd294190d0843cb2f8f
+DIST miniupnpd-2.3.3.tar.gz 260079 BLAKE2B 4b32e05bc7002bc7edc946f01b1984f3d184e0e9949a9685ffa5351ece9dacc09dc48567cc6f68972343a1921f4ceb5c541d4b557c4991f311289a511c492efa SHA512 98915e3c1410d6753a58133596bad012fea205f36ae4991c2cf4b358d1e905e029287cfcf1aa97283c2e3c1cb8c20655bff35d49a37ae8756739e33c4ae3e7ef
+DIST miniupnpd-2.3.3.tar.gz.sig 543 BLAKE2B 33b6166ba64a7a7c1b019c84d8a623d2905f32b41ea6b7cfd96c180e3d8738af264b5f073a9503c037f4609f15cb73f039701368eba63764de9edc79159961f6 SHA512 f2b167fec659e2f366ac180e8245c35e2907f5fb6be31fb62aad072e8a67868b995dd9400b4f41ebdfe2dcb46df583e5a1d6260f93c9b3eb25ba46bc7f6106dd
diff --git a/net-misc/miniupnpd/miniupnpd-2.3.3.ebuild b/net-misc/miniupnpd/miniupnpd-2.3.3.ebuild
new file mode 100644
index 000000000000..0bed1072de26
--- /dev/null
+++ b/net-misc/miniupnpd/miniupnpd-2.3.3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs verify-sig
+
+DESCRIPTION="MiniUPnP IGD Daemon"
+HOMEPAGE="
+ http://miniupnp.free.fr/
+ https://miniupnp.tuxfamily.org/
+ https://github.com/miniupnp/miniupnp/
+"
+SRC_URI="
+ https://miniupnp.tuxfamily.org/files/${P}.tar.gz
+ verify-sig? (
+ https://miniupnp.tuxfamily.org/files/${P}.tar.gz.sig
+ )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+leasefile igd2 ipv6 nftables pcp-peer portinuse strict"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ sys-apps/util-linux:=
+ dev-libs/openssl:0=
+ !nftables? (
+ >=net-firewall/iptables-1.4.6:0=[ipv6(+)?]
+ net-libs/libnfnetlink:=
+ net-libs/libmnl:=
+ )
+ nftables? (
+ net-firewall/nftables
+ net-libs/libnftnl:=
+ net-libs/libmnl:=
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ elibc_musl? ( sys-libs/queue-standalone )
+"
+BDEPEND="
+ sys-apps/lsb-release
+ verify-sig? ( sec-keys/openpgp-keys-miniupnp )
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/miniupnp.asc
+
+src_prepare() {
+ default
+
+ # fails without a default route
+ sed -i -e 's:EXTIF=.*:EXTIF=lo:' testgetifaddr.sh || die
+}
+
+src_configure() {
+ local opts=(
+ --vendorcfg
+ $(usex igd2 '--igd2' '')
+ $(usex ipv6 '--ipv6' '')
+ $(usex leasefile '--leasefile' '')
+ $(usex portinuse '--portinuse' '')
+ $(usex pcp-peer '--pcp-peer' '')
+ $(usex strict '--strict' '')
+ --firewall=$(usex nftables nftables iptables)
+ )
+
+ # custom script
+ ./configure "${opts[@]}" || die
+ # prevent gzipping manpage
+ sed -i -e '/gzip/d' Makefile || die
+}
+
+src_compile() {
+ # By default, it builds a bunch of unittests that are missing wrapper
+ # scripts in the tarball
+ emake CC="$(tc-getCC)" STRIP=true miniupnpd
+}
+
+src_test() {
+ emake CC="$(tc-getCC)" check
+}
+
+src_install() {
+ emake PREFIX="${ED}" STRIP=true install
+
+ local confd_seds=()
+ if use nftables; then
+ confd_seds+=( -e 's/^iptables_scripts=/#&/' )
+ else
+ confd_seds+=( -e 's/^nftables_scripts=/#&/' )
+ fi
+ if ! use ipv6 || use nftables; then
+ confd_seds+=( -e 's/^ip6tables_scripts=/#&/' )
+ fi
+
+ newinitd "${FILESDIR}"/${PN}-init.d-r2 ${PN}
+ newconfd - ${PN} < <(sed "${confd_seds[@]}" \
+ "${FILESDIR}"/${PN}-conf.d-r2 || die)
+}
+
+pkg_postinst() {
+ elog "Please correct the external interface in the top of the two"
+ elog "scripts in /etc/miniupnpd and edit the config file in there too"
+}