summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-11-14 09:06:53 +0100
committerJeroen Roovers <jer@gentoo.org>2016-11-14 09:06:53 +0100
commita56b63d2e3f5a4fde96f35c284b47036252d6e25 (patch)
treefa235f16552d8fe537d0937782c9a296ab2db525 /net-misc
parentsci-physics/heppdt: Removing EAPI 4 version 3.04.01 (diff)
downloadgentoo-a56b63d2e3f5a4fde96f35c284b47036252d6e25.tar.gz
gentoo-a56b63d2e3f5a4fde96f35c284b47036252d6e25.tar.bz2
gentoo-a56b63d2e3f5a4fde96f35c284b47036252d6e25.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.11.14.1.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 5d7f5f2e24e1..6dd925c862b7 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -2,3 +2,4 @@ DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b
DIST youtube-dl-2016.09.19.tar.gz 2395739 SHA256 276637e83525778a83d0457f6b9fbc29d6109bc8366d43125432ce835d28545e SHA512 a8fb1ce054e25180eab3969c898d976dec157901931b66cddde0fecd55ef322e64c13a70d50de945849cbc4ccbf8be0aede845cbb8ea390bba34f51fec0533bf WHIRLPOOL e58d38e49d58b86d8eb25b40427046955e011bf57b0862c433ebe459c0268905bff67188c03bb612593d15b3d1f3408a95b510ad6f863d0144ee4307ed012aba
DIST youtube-dl-2016.11.04.tar.gz 2463253 SHA256 9622b29b81587278a00e39e4206e7c52555d240cbbb44242f237660169e8d531 SHA512 063954b3980e5f946eb54c27bfd7593f1f4076d452fb8edf495bee91db66d5a31efc8038dbbdd39d5b11c3e144104e6dc858dcff678bd9dba7ebbafd134a30ca WHIRLPOOL a3176dad02e988f8e315901be2d93b57f3c437b9fc7b91f056f7db3a7874dfe14e2b0354c2570b5996f9f67970cdad2b9fa888964a00ac2b5160dbd9327f5aa9
DIST youtube-dl-2016.11.08.1.tar.gz 2465978 SHA256 95d45438254c949952127b269451da861682fb06a7ef62b5f5dc75bc40bfaeeb SHA512 2c3bbe915e624f971e441ae1f0848ee178c2e323bad83ef3db344895316e347cebd3bc265290edb10a051286b0bdf3124961999f5ec944caf36752396380ee59 WHIRLPOOL d273c038300ad4dc86ca5e0c5d02c72dbc06f4b6d3c712785fc08154ca776e16a60f79663bb5e65a605d6b6d473b512b64d10bee79d41e242579d2026f6db88b
+DIST youtube-dl-2016.11.14.1.tar.gz 2468850 SHA256 d96b5e5fe7de67ea01c2be746c00dc78ffbf3f74654aa989db8baaf153243537 SHA512 1140fd617f82c64dda0136d89beb3c7fbaf5c747483032efd3983e494e47fc190d2025c89d80fe61688a9af5dc55da0d9e16afde0e6b65e59643af89f0203e4d WHIRLPOOL 5fb164fd2d2bdfb5eb0f7f72526cbca0082cf8b0993b562e43d0f78b963a4406d593221752a8550443c202456b0584a0a26a40cff26b25da2b3e3dd974b7fb81
diff --git a/net-misc/youtube-dl/youtube-dl-2016.11.14.1.ebuild b/net-misc/youtube-dl/youtube-dl-2016.11.14.1.ebuild
new file mode 100644
index 000000000000..703df472c017
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.11.14.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo ruleporn
+ sexu slutload spankbang spankwire sunporno thisav tube8 vporn
+ watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber pornhub redtube xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}