summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2022-08-18 22:46:10 +0200
committerSam James <sam@gentoo.org>2022-08-18 22:01:39 +0100
commita8798b7bd83135647851684f6bf1cd8e1322040c (patch)
treecc65783b5b901859cd348de7551fb05f9704b9f8 /net-misc
parentmedia-gfx/tuxpaint-stamps: Stabilize 20211125 ppc, #865313 (diff)
downloadgentoo-a8798b7bd83135647851684f6bf1cd8e1322040c.tar.gz
gentoo-a8798b7bd83135647851684f6bf1cd8e1322040c.tar.bz2
gentoo-a8798b7bd83135647851684f6bf1cd8e1322040c.zip
net-misc/asterisk: ./configure fixes.
1. there is a ./configure in menuselect, so eautoreconf should run there too. 2. SED= is set in that menuselect/configure only after using, resulting in "./configure: line 5027: -e: command not found", which ends up that libxml-2.0 is detected, but the CFLAGS for the package isn't correctly set, resulting in failure at a later stage to #include <libxml/parser.h> Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/26916 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/asterisk/asterisk-13.38.3-r3.ebuild3
-rw-r--r--net-misc/asterisk/asterisk-16.22.0-r1.ebuild3
-rw-r--r--net-misc/asterisk/asterisk-16.23.0-r1.ebuild3
-rw-r--r--net-misc/asterisk/asterisk-16.24.0-r1.ebuild3
-rw-r--r--net-misc/asterisk/asterisk-16.26.1.ebuild4
-rw-r--r--net-misc/asterisk/asterisk-16.27.0.ebuild4
-rw-r--r--net-misc/asterisk/asterisk-18.10.0-r1.ebuild3
-rw-r--r--net-misc/asterisk/asterisk-18.13.0.ebuild3
-rw-r--r--net-misc/asterisk/asterisk-18.8.0-r1.ebuild3
-rw-r--r--net-misc/asterisk/asterisk-18.9.0-r1.ebuild3
10 files changed, 22 insertions, 10 deletions
diff --git a/net-misc/asterisk/asterisk-13.38.3-r3.ebuild b/net-misc/asterisk/asterisk-13.38.3-r3.ebuild
index f751e394bb25..2bd6004948b9 100644
--- a/net-misc/asterisk/asterisk-13.38.3-r3.ebuild
+++ b/net-misc/asterisk/asterisk-13.38.3-r3.ebuild
@@ -139,7 +139,8 @@ pkg_setup() {
src_prepare() {
default
- AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" eautoreconf
+ AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" \
+ AC_CONFIG_SUBDIRS=menuselect eautoreconf
}
src_configure() {
diff --git a/net-misc/asterisk/asterisk-16.22.0-r1.ebuild b/net-misc/asterisk/asterisk-16.22.0-r1.ebuild
index d93cebbd447b..b4d9db65f36e 100644
--- a/net-misc/asterisk/asterisk-16.22.0-r1.ebuild
+++ b/net-misc/asterisk/asterisk-16.22.0-r1.ebuild
@@ -140,7 +140,8 @@ pkg_setup() {
src_prepare() {
default
- AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" eautoreconf
+ AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" \
+ AC_CONFIG_SUBDIRS=menuselect eautoreconf
}
src_configure() {
diff --git a/net-misc/asterisk/asterisk-16.23.0-r1.ebuild b/net-misc/asterisk/asterisk-16.23.0-r1.ebuild
index b1734d7ddad9..5651421ddd25 100644
--- a/net-misc/asterisk/asterisk-16.23.0-r1.ebuild
+++ b/net-misc/asterisk/asterisk-16.23.0-r1.ebuild
@@ -140,7 +140,8 @@ pkg_setup() {
src_prepare() {
default
- AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" eautoreconf
+ AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" \
+ AC_CONFIG_SUBDIRS=menuselect eautoreconf
}
src_configure() {
diff --git a/net-misc/asterisk/asterisk-16.24.0-r1.ebuild b/net-misc/asterisk/asterisk-16.24.0-r1.ebuild
index b1734d7ddad9..5651421ddd25 100644
--- a/net-misc/asterisk/asterisk-16.24.0-r1.ebuild
+++ b/net-misc/asterisk/asterisk-16.24.0-r1.ebuild
@@ -140,7 +140,8 @@ pkg_setup() {
src_prepare() {
default
- AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" eautoreconf
+ AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" \
+ AC_CONFIG_SUBDIRS=menuselect eautoreconf
}
src_configure() {
diff --git a/net-misc/asterisk/asterisk-16.26.1.ebuild b/net-misc/asterisk/asterisk-16.26.1.ebuild
index a2765b2dde1f..357286071693 100644
--- a/net-misc/asterisk/asterisk-16.26.1.ebuild
+++ b/net-misc/asterisk/asterisk-16.26.1.ebuild
@@ -140,7 +140,8 @@ pkg_setup() {
src_prepare() {
default
- AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" eautoreconf
+ AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" \
+ AC_CONFIG_SUBDIRS=menuselect eautoreconf
}
src_configure() {
@@ -148,6 +149,7 @@ src_configure() {
local copt cstate
econf \
+ SED=sed \
LUA_VERSION="${ELUA#lua}" \
--libdir="/usr/$(get_libdir)" \
--localstatedir="/var" \
diff --git a/net-misc/asterisk/asterisk-16.27.0.ebuild b/net-misc/asterisk/asterisk-16.27.0.ebuild
index a2765b2dde1f..357286071693 100644
--- a/net-misc/asterisk/asterisk-16.27.0.ebuild
+++ b/net-misc/asterisk/asterisk-16.27.0.ebuild
@@ -140,7 +140,8 @@ pkg_setup() {
src_prepare() {
default
- AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" eautoreconf
+ AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" \
+ AC_CONFIG_SUBDIRS=menuselect eautoreconf
}
src_configure() {
@@ -148,6 +149,7 @@ src_configure() {
local copt cstate
econf \
+ SED=sed \
LUA_VERSION="${ELUA#lua}" \
--libdir="/usr/$(get_libdir)" \
--localstatedir="/var" \
diff --git a/net-misc/asterisk/asterisk-18.10.0-r1.ebuild b/net-misc/asterisk/asterisk-18.10.0-r1.ebuild
index e9039223c4c5..ef4b7a3b8d86 100644
--- a/net-misc/asterisk/asterisk-18.10.0-r1.ebuild
+++ b/net-misc/asterisk/asterisk-18.10.0-r1.ebuild
@@ -138,7 +138,8 @@ pkg_setup() {
src_prepare() {
default
- AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" eautoreconf
+ AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" \
+ AC_CONFIG_SUBDIRS=menuselect eautoreconf
}
src_configure() {
diff --git a/net-misc/asterisk/asterisk-18.13.0.ebuild b/net-misc/asterisk/asterisk-18.13.0.ebuild
index 1b1230192ff3..cdb30c050d92 100644
--- a/net-misc/asterisk/asterisk-18.13.0.ebuild
+++ b/net-misc/asterisk/asterisk-18.13.0.ebuild
@@ -138,7 +138,8 @@ pkg_setup() {
src_prepare() {
default
- AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" eautoreconf
+ AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" \
+ AC_CONFIG_SUBDIRS=menuselect eautoreconf
}
src_configure() {
diff --git a/net-misc/asterisk/asterisk-18.8.0-r1.ebuild b/net-misc/asterisk/asterisk-18.8.0-r1.ebuild
index bc3f597e95ac..1242bbbadaa3 100644
--- a/net-misc/asterisk/asterisk-18.8.0-r1.ebuild
+++ b/net-misc/asterisk/asterisk-18.8.0-r1.ebuild
@@ -138,7 +138,8 @@ pkg_setup() {
src_prepare() {
default
- AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" eautoreconf
+ AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" \
+ AC_CONFIG_SUBDIRS=menuselect eautoreconf
}
src_configure() {
diff --git a/net-misc/asterisk/asterisk-18.9.0-r1.ebuild b/net-misc/asterisk/asterisk-18.9.0-r1.ebuild
index e9039223c4c5..ef4b7a3b8d86 100644
--- a/net-misc/asterisk/asterisk-18.9.0-r1.ebuild
+++ b/net-misc/asterisk/asterisk-18.9.0-r1.ebuild
@@ -138,7 +138,8 @@ pkg_setup() {
src_prepare() {
default
- AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" eautoreconf
+ AT_M4DIR="autoconf third-party third-party/pjproject third-party/jansson" \
+ AC_CONFIG_SUBDIRS=menuselect eautoreconf
}
src_configure() {