summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2018-12-05 10:59:47 -0800
committerPatrick McLean <chutzpah@gentoo.org>2018-12-05 11:00:00 -0800
commitabb033282e05e40401ec49677a1b8c7ecc64ad9e (patch)
treee45042d983257d246342ff744fa467fbd3e7bd98 /net-misc
parentsys-apps/i2c-tools: Drop old (diff)
downloadgentoo-abb033282e05e40401ec49677a1b8c7ecc64ad9e.tar.gz
gentoo-abb033282e05e40401ec49677a1b8c7ecc64ad9e.tar.bz2
gentoo-abb033282e05e40401ec49677a1b8c7ecc64ad9e.zip
net-misc/lldpd: Version bump to 1.0.2
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/lldpd/Manifest1
-rw-r--r--net-misc/lldpd/files/lldpd-1.0.2-seccomp-add-misc.patch12
-rw-r--r--net-misc/lldpd/lldpd-1.0.2.ebuild104
3 files changed, 117 insertions, 0 deletions
diff --git a/net-misc/lldpd/Manifest b/net-misc/lldpd/Manifest
index 5b629f66af8e..8e9d18d67374 100644
--- a/net-misc/lldpd/Manifest
+++ b/net-misc/lldpd/Manifest
@@ -1,2 +1,3 @@
DIST lldpd-0.9.3.tar.gz 1601102 BLAKE2B 0ba31d20dad9770c93fa4930a7c439273c36e5cebdb0b4a1674f0a375008f642e33d71b9668c91313ec4bb3311e1b4bd22d0996ed6347d2cacfd7cce24536a58 SHA512 0d40d77bfde78f9ceece56968981f3a36bd7e683b12de05e84e5da0409b8e0d06062e5d665942637a66164af0254a6ac3d1a327aab3bcb48ec91ecfdd2693283
DIST lldpd-1.0.1.tar.gz 1590903 BLAKE2B 37ff1c042537ac31f394986f1bbd3faf13105d07f340ed045a4bbc196912c0c017a5d60b2c6a89b0da9faa5a7ff8e9c4ef0d4d01a39504a31c23288a89eb92a3 SHA512 61b2a7a3a78276c613c6d0b34eb625e69e5c8a206b6658a167d6a09ac6d0e1c943e46c0ff6fc3538a791d9947f193185b65848da581b3d6ecb9bc0befadde8dd
+DIST lldpd-1.0.2.tar.gz 1605391 BLAKE2B 8050b7461d4cb00c8db3c5eaa9c1fdabc9715e2b673efd9c76024448aa46363836f66b9ded9e0aa27414a742c7b1bce789394045a304839ba376e50d3d3851e4 SHA512 910a0f0211eb39deaa3291c37ec0eaaa5f762565ae2198d568b6c9ddaaa62f1f2283bc92013db54852e22a68aea4e0ba09ea25f9fb368702755e69c4de919e0b
diff --git a/net-misc/lldpd/files/lldpd-1.0.2-seccomp-add-misc.patch b/net-misc/lldpd/files/lldpd-1.0.2-seccomp-add-misc.patch
new file mode 100644
index 000000000000..c5e6d2edb78f
--- /dev/null
+++ b/net-misc/lldpd/files/lldpd-1.0.2-seccomp-add-misc.patch
@@ -0,0 +1,12 @@
+diff --git a/src/daemon/priv-seccomp.c b/src/daemon/priv-seccomp.c
+index fe48ad3..791b76b 100644
+--- a/src/daemon/priv-seccomp.c
++++ b/src/daemon/priv-seccomp.c
+@@ -148,6 +148,7 @@ priv_seccomp_init(int remote, int child)
+ if ((rc = seccomp_rule_add(ctx, SCMP_ACT_ALLOW, SCMP_SYS(read), 0)) < 0 ||
+ (rc = seccomp_rule_add(ctx, SCMP_ACT_ALLOW, SCMP_SYS(write), 0)) < 0 || /* write needed for */
+ (rc = seccomp_rule_add(ctx, SCMP_ACT_ALLOW, SCMP_SYS(open), 0)) < 0 ||
++ (rc = seccomp_rule_add(ctx, SCMP_ACT_ALLOW, SCMP_SYS(lseek), 0)) < 0 ||
+ (rc = seccomp_rule_add(ctx, SCMP_ACT_ALLOW, SCMP_SYS(openat), 0)) < 0 ||
+ (rc = seccomp_rule_add(ctx, SCMP_ACT_ALLOW, SCMP_SYS(fcntl), 0)) < 0 ||
+ (rc = seccomp_rule_add(ctx, SCMP_ACT_ALLOW, SCMP_SYS(kill), 0)) < 0 ||
diff --git a/net-misc/lldpd/lldpd-1.0.2.ebuild b/net-misc/lldpd/lldpd-1.0.2.ebuild
new file mode 100644
index 000000000000..09b8552f81f0
--- /dev/null
+++ b/net-misc/lldpd/lldpd-1.0.2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils user systemd bash-completion-r1 autotools
+
+DESCRIPTION="Implementation of IEEE 802.1ab (LLDP)"
+HOMEPAGE="https://vincentbernat.github.com/lldpd/"
+SRC_URI="http://media.luffy.cx/files/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cdp doc +dot1 +dot3 edp fdp graph +lldpmed old-kernel sanitizers
+ seccomp sonmp snmp static-libs test readline xml zsh-completion"
+
+RDEPEND="dev-libs/libbsd
+ >=dev-libs/libevent-2.0.5:=
+ snmp? ( net-analyzer/net-snmp[extensible(+)] )
+ xml? ( dev-libs/libxml2 )
+ seccomp? ( sys-libs/libseccomp )
+ zsh-completion? ( app-shells/zsh )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ graph? ( app-doc/doxygen[dot] )
+ !graph? ( app-doc/doxygen )
+ )
+ test? ( dev-libs/check )"
+
+REQUIRED_USE="graph? ( doc )"
+
+PATCHES=(
+ "${FILESDIR}/lldpd-0.9.5-seccomp-add-socket-ops.patch"
+ "${FILESDIR}/lldpd-1.0.1-seccomp-add-brk.patch"
+ "${FILESDIR}/lldpd-1.0.2-seccomp-add-misc.patch"
+)
+
+pkg_setup() {
+ ebegin "Creating lldpd user and group"
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+ eend $?
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --without-embedded-libevent \
+ --with-privsep-user=${PN} \
+ --with-privsep-group=${PN} \
+ --with-privsep-chroot=/run/${PN} \
+ --with-lldpd-ctl-socket=/run/${PN}.socket \
+ --with-lldpd-pid-file=/run/${PN}.pid \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable cdp) \
+ $(use_enable doc doxygen-man) \
+ $(use_enable doc doxygen-pdf) \
+ $(use_enable doc doxygen-html) \
+ $(use_enable dot1) \
+ $(use_enable dot3) \
+ $(use_enable edp) \
+ $(use_enable fdp) \
+ $(use_enable graph doxygen-dot) \
+ $(use_enable lldpmed) \
+ $(use_enable old-kernel oldies) \
+ $(use_enable sonmp) \
+ $(use_enable static-libs static) \
+ $(use_with readline) \
+ $(use_enable sanitizers) \
+ $(use_with seccomp) \
+ $(use_with snmp) \
+ $(use_with xml)
+}
+
+src_compile() {
+ emake
+ use doc && emake doxygen-doc
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+
+ newinitd "${FILESDIR}"/${PN}-initd-5 ${PN}
+ newconfd "${FILESDIR}"/${PN}-confd-1 ${PN}
+ newbashcomp src/client/completion/lldpcli lldpcli
+
+ use doc && dodoc -r doxygen/html
+
+ insinto /etc
+ doins "${FILESDIR}/lldpd.conf"
+ keepdir /etc/${PN}.d
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_newtmpfilesd "${FILESDIR}"/tmpfilesd ${PN}.conf
+}