summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-12-19 10:49:13 +0100
committerPacho Ramos <pacho@gentoo.org>2022-12-19 10:49:13 +0100
commitac9de419ed2d6f29b84de420c318879164c38a08 (patch)
tree0e42f18691bfc5ebede8ae89c30e044984518c15 /net-misc
parentdev-libs/libayatana-appindicator: new package, add 0.5.91 (diff)
downloadgentoo-ac9de419ed2d6f29b84de420c318879164c38a08.tar.gz
gentoo-ac9de419ed2d6f29b84de420c318879164c38a08.tar.bz2
gentoo-ac9de419ed2d6f29b84de420c318879164c38a08.zip
net-misc/r8168: Fix support for kernel 6.1
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/r8168/files/r8168-8.051.02-6.1-fix.patch25
-rw-r--r--net-misc/r8168/r8168-8.051.02.ebuild4
2 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/r8168/files/r8168-8.051.02-6.1-fix.patch b/net-misc/r8168/files/r8168-8.051.02-6.1-fix.patch
new file mode 100644
index 000000000000..9a9e3e539259
--- /dev/null
+++ b/net-misc/r8168/files/r8168-8.051.02-6.1-fix.patch
@@ -0,0 +1,25 @@
+From 39dd0fd2e5dc45cd63113f33a9890e36c304916d Mon Sep 17 00:00:00 2001
+From: zu1k <i@zu1k.com>
+Date: Sat, 29 Oct 2022 21:57:39 +0800
+Subject: [PATCH] Adapted for Linux 6.1
+
+---
+ src/r8168.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/r8168.h b/src/r8168.h
+index 662974a..baf48c6 100755
+--- a/src/r8168.h
++++ b/src/r8168.h
+@@ -561,7 +561,11 @@ typedef int *napi_budget;
+ typedef struct napi_struct *napi_ptr;
+ typedef int napi_budget;
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 1, 0)
++#define RTL_NAPI_CONFIG(ndev, priv, function, weight) netif_napi_add(ndev, &priv->napi, function)
++#else
+ #define RTL_NAPI_CONFIG(ndev, priv, function, weight) netif_napi_add(ndev, &priv->napi, function, weight)
++#endif
+ #define RTL_NAPI_QUOTA(budget, ndev) min(budget, budget)
+ #define RTL_GET_PRIV(stuct_ptr, priv_struct) container_of(stuct_ptr, priv_struct, stuct_ptr)
+ #define RTL_GET_NETDEV(priv_ptr) struct net_device *dev = priv_ptr->dev;
diff --git a/net-misc/r8168/r8168-8.051.02.ebuild b/net-misc/r8168/r8168-8.051.02.ebuild
index 4258fbb99cdb..853cd629f555 100644
--- a/net-misc/r8168/r8168-8.051.02.ebuild
+++ b/net-misc/r8168/r8168-8.051.02.ebuild
@@ -24,6 +24,10 @@ IUSE="use-firmware"
CONFIG_CHECK="~!R8169"
WARNING_R8169="CONFIG_R8169 is enabled. ${P} will not be loaded unless kernel driver Realtek 8169 PCI Gigabit Ethernet (CONFIG_R8169) is DISABLED."
+PATCHES=(
+ "${FILESDIR}/${PN}-8.051.02-6.1-fix.patch"
+)
+
pkg_setup() {
linux-mod_pkg_setup
BUILD_PARAMS="KERNELDIR=${KV_DIR}"