summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-02 09:49:27 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-02 10:43:18 +0200
commitaf73ad4881c33899d4a796aec673d4021e697e22 (patch)
treed8e194e3c608c7287ab9b4be01ba133c6eab420b /net-misc
parentmedia-sound/mumble: Bump to version 1.2.10 (bug #552092) (diff)
downloadgentoo-af73ad4881c33899d4a796aec673d4021e697e22.tar.gz
gentoo-af73ad4881c33899d4a796aec673d4021e697e22.tar.bz2
gentoo-af73ad4881c33899d4a796aec673d4021e697e22.zip
net-misc/autoupnp: Version bump with miniupnpc compat fix
Package-Manager: portage-2.2.22
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/autoupnp/Manifest1
-rw-r--r--net-misc/autoupnp/autoupnp-0.4.7.ebuild33
-rw-r--r--net-misc/autoupnp/autoupnp-9999.ebuild18
3 files changed, 46 insertions, 6 deletions
diff --git a/net-misc/autoupnp/Manifest b/net-misc/autoupnp/Manifest
index 2633bf042912..8a8b485ebcb1 100644
--- a/net-misc/autoupnp/Manifest
+++ b/net-misc/autoupnp/Manifest
@@ -1 +1,2 @@
DIST autoupnp-0.4.6.tar.bz2 240257 SHA256 a8d0a207074fafdb322510fd29a25eb4bf62da9468ea3dc45e7c9740faeccab7 SHA512 570ae76d940879a375e9336cb62cce8b2e007c57df6cbebee5878cf6a71d1fe5853218166ba0ee794586fa20a7c62b158aae9242b30880f6fe110c9bb1502ba1 WHIRLPOOL 4b2d848f36e3f2848e6f08f71296b5cf3fe7794bdfc9e6495428b3b3ae9283ed15e81de0bec2fdf0b36173d59a4c7dbec5dbef30bf3a0ba24e320de313cb20ab
+DIST autoupnp-0.4.7.tar.bz2 264916 SHA256 f68c80ae6e8061417bef2fb2ad554d49f0bf4b5ef2def84600a4b67fa756c703 SHA512 2c6bb3421fecbffea2a63ea1e930b7c789459d4626a0f281abe0e9bb62e5efc772475d4bf0c9f13fe2e9e13417940c6eb17408e6aae28bc24a4fc2e16d4dc8de WHIRLPOOL d08f6011d286f37d70d206cabe148a95e02b71bf9fdc13852da038bb87f4dde99fb206382e12879d81bff3dd5f133aae0b4bfb4c4168f8b76a4a0a2d4fbc4168
diff --git a/net-misc/autoupnp/autoupnp-0.4.7.ebuild b/net-misc/autoupnp/autoupnp-0.4.7.ebuild
new file mode 100644
index 000000000000..b7f066586cb7
--- /dev/null
+++ b/net-misc/autoupnp/autoupnp-0.4.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Automatic open port forwarder using UPnP"
+HOMEPAGE="https://bitbucket.org/mgorny/autoupnp/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="net-libs/miniupnpc:0=
+ libnotify? ( x11-libs/libtinynotify:0= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf=(
+ $(use_with libnotify)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/net-misc/autoupnp/autoupnp-9999.ebuild b/net-misc/autoupnp/autoupnp-9999.ebuild
index be3f1f8a8c9b..0dc42eeb1d46 100644
--- a/net-misc/autoupnp/autoupnp-9999.ebuild
+++ b/net-misc/autoupnp/autoupnp-9999.ebuild
@@ -5,17 +5,16 @@
EAPI=5
#if LIVE
-AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
-inherit git-r3
+inherit autotools git-r3
#endif
-inherit autotools-utils
+inherit eutils
DESCRIPTION="Automatic open port forwarder using UPnP"
HOMEPAGE="https://bitbucket.org/mgorny/autoupnp/"
-SRC_URI="https://www.bitbucket.org/mgorny/${PN}/${P}.tar.bz2"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
@@ -29,12 +28,19 @@ DEPEND="${RDEPEND}"
#if LIVE
KEYWORDS=
SRC_URI=
+
+src_prepare() { eautoreconf; }
#endif
src_configure() {
- myeconfargs=(
+ local myconf=(
$(use_with libnotify)
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
}