summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 22:25:06 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:28 +0100
commitb8e18555a1ea2e353768827337591b8763da7e2c (patch)
tree86676c38126c379d03a4eeda98b52690f4d15b6f /net-misc
parentnet-misc/sntpd: drop 3.0-r1 (diff)
downloadgentoo-b8e18555a1ea2e353768827337591b8763da7e2c.tar.gz
gentoo-b8e18555a1ea2e353768827337591b8763da7e2c.tar.bz2
gentoo-b8e18555a1ea2e353768827337591b8763da7e2c.zip
net-misc/wol: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wol/wol-0.7.1-r3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/wol/wol-0.7.1-r3.ebuild b/net-misc/wol/wol-0.7.1-r3.ebuild
new file mode 100644
index 000000000000..4b4ba0165cd9
--- /dev/null
+++ b/net-misc/wol/wol-0.7.1-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Implements Wake On LAN (Magic Paket) functionality in a small program"
+HOMEPAGE="http://ahh.sourceforge.net/wol/"
+SRC_URI="mirror://sourceforge/ahh/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86"
+IUSE="nls"
+
+PATCHES=( "${FILESDIR}/${P}-musl.patch" )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-rpath
+ $(use_enable nls)
+ )
+
+ econf ${myeconfargs[@]}
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}