summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2023-06-08 02:03:03 +1000
committerSam James <sam@gentoo.org>2023-06-09 07:15:36 +0100
commitca9582453591aa1db46d75e817f0d1b79ff371bc (patch)
tree1bc5b702ab33926e79140d589aee4913f9644624 /net-misc
parentsys-devel/gcc-apple: drop toolchain.eclass (diff)
downloadgentoo-ca9582453591aa1db46d75e817f0d1b79ff371bc.tar.gz
gentoo-ca9582453591aa1db46d75e817f0d1b79ff371bc.tar.bz2
gentoo-ca9582453591aa1db46d75e817f0d1b79ff371bc.zip
net-misc/curl: enable parallel tests
parallel tests shave a solid 6 minutes off a curl build-and-test round on ~amd64. Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/curl/curl-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-misc/curl/curl-9999.ebuild b/net-misc/curl/curl-9999.ebuild
index bd074d803563..770410045476 100644
--- a/net-misc/curl/curl-9999.ebuild
+++ b/net-misc/curl/curl-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/danielstenberg.asc
-inherit autotools multilib-minimal prefix verify-sig
+inherit autotools multilib-minimal multiprocessing prefix verify-sig
DESCRIPTION="A Client that groks URLs"
HOMEPAGE="https://curl.se/"
@@ -318,7 +318,10 @@ multilib_src_test() {
# Note: if needed, we can skip specific tests. See e.g. Fedora's packaging
# or just read https://github.com/curl/curl/tree/master/tests#run.
# Note: we don't run the testsuite for cross-compilation.
- multilib_is_native_abi && emake test TFLAGS="-n -v -a -k -am -p"
+ # Upstream recommend 7*nproc as a starting point for parallel tests.
+ # The network sandbox causes tests 241 and 1083 to fail; these are typically skipped
+ # as most gentoo users don't have an 'ip6-localhost'
+ multilib_is_native_abi && emake test TFLAGS="-n -v -a -k -am -p -j$((7*$(makeopts_jobs))) !241 !1083"
}
multilib_src_install_all() {