summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-23 01:28:49 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-23 02:06:59 -0400
commitcb49b192886e9c956af99d591720ed57560bc37a (patch)
tree34823c6f034f68f0bf47b88fd100bae0b32f0c89 /net-misc
parentdev-python/requests: allow charset normalizer >=2 and <4 (diff)
downloadgentoo-cb49b192886e9c956af99d591720ed57560bc37a.tar.gz
gentoo-cb49b192886e9c956af99d591720ed57560bc37a.tar.bz2
gentoo-cb49b192886e9c956af99d591720ed57560bc37a.zip
net-misc/ytfzf: add 2.5.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ytfzf/Manifest1
-rw-r--r--net-misc/ytfzf/files/ytfzf-2.5.1-ueberzug.patch10
-rw-r--r--net-misc/ytfzf/ytfzf-2.5.1.ebuild63
3 files changed, 74 insertions, 0 deletions
diff --git a/net-misc/ytfzf/Manifest b/net-misc/ytfzf/Manifest
index e3c3a4ca32c4..322f9374caca 100644
--- a/net-misc/ytfzf/Manifest
+++ b/net-misc/ytfzf/Manifest
@@ -1 +1,2 @@
DIST ytfzf-2.5.0.tar.gz 3260280 BLAKE2B 33535afc6be18fe9efeddf666ccdc646db227fcb601a52baeaca91b9316b87b1300fdab50ceca5eb9e21fef5571a87e917f78f71b97e7ec2abbebf5158b4487d SHA512 43e366694687be517a0b3da0d16e423f32046ab5de92368748e87c622f43e34bd1037f01b37fcb05ae8ce87ca536672cf3f5ca2b2608bab07ec9f4abeabb61ec
+DIST ytfzf-2.5.1.tar.gz 3263331 BLAKE2B 690a108e7b2e744a33acc67ea73ec28af87050c27af0e1cf274b163aa3f9699ee22b10ea7ecf88559c56c57443e686ad5e03ea61dc21571310425280de24d764 SHA512 00ec6a17c465f1590f61590ff45763d4e58cd7a281868817987b199b62c463f38c0543a0f6a71b983bd256f07f8c3cd25a0211945db2a74dada2078a42b69a51
diff --git a/net-misc/ytfzf/files/ytfzf-2.5.1-ueberzug.patch b/net-misc/ytfzf/files/ytfzf-2.5.1-ueberzug.patch
new file mode 100644
index 000000000000..5ebb36564f42
--- /dev/null
+++ b/net-misc/ytfzf/files/ytfzf-2.5.1-ueberzug.patch
@@ -0,0 +1,10 @@
+https://github.com/pystardust/ytfzf/issues/592
+--- a/ytfzf
++++ b/ytfzf
+@@ -1698,4 +1698,4 @@
+ mkfifo "$UEBERZUG_FIFO"
+- ueberzug layer --parser json < "$UEBERZUG_FIFO" &
+- exec 3> "$UEBERZUG_FIFO" > "$thumbnail_debug_log" 2>&1 # to keep the fifo open
++ ueberzug layer --parser json < "$UEBERZUG_FIFO" > "$thumbnail_debug_log" 2>&1 &
++ exec 3> "$UEBERZUG_FIFO" # to keep the fifo open
+ ;;
diff --git a/net-misc/ytfzf/ytfzf-2.5.1.ebuild b/net-misc/ytfzf/ytfzf-2.5.1.ebuild
new file mode 100644
index 000000000000..82ded86e3370
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-2.5.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X minimal"
+
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ virtual/awk
+ !minimal? (
+ X? ( media-gfx/ueberzug )
+ app-shells/fzf
+ media-video/mpv[lua]
+ net-misc/yt-dlp
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ueberzug.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i "/^: ...YTFZF_SYSTEM_ADDON_DIR/s|/usr/local|${EPREFIX}/usr|" ytfzf || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+
+ emake "${emakeargs[@]}" addons doc install
+ einstalldocs
+
+ rm -r "${ED}"/usr/share/licenses || die
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu
+ optfeature "desktop notifications" x11-libs/libnotify
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note that ${PN} supports many methods to display menus/thumbnails."
+ elog "This ebuild primarily covers defaults and major features, additional"
+ elog "dependencies may be needed for others. Set USE=minimal if want full"
+ elog "control over optional dependencies (e.g. fzf is optional if use dmenu)."
+ fi
+}