summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-24 15:24:00 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-24 15:32:39 +0200
commitd036d526b38b8b7586d78938188a29ba8883d75e (patch)
tree1dc7f1d1ebcce5613d5c53abe7483c0bfbb17886 /net-misc
parentdev-perl/Bio-SamTools: Set proper slot (diff)
downloadgentoo-d036d526b38b8b7586d78938188a29ba8883d75e.tar.gz
gentoo-d036d526b38b8b7586d78938188a29ba8883d75e.tar.bz2
gentoo-d036d526b38b8b7586d78938188a29ba8883d75e.zip
net-misc/netifrc: Fix missing interface types (#588872)
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/netifrc/files/netifrc-0.4.0-interface-types.patch26
-rw-r--r--net-misc/netifrc/netifrc-0.4.0-r1.ebuild72
2 files changed, 98 insertions, 0 deletions
diff --git a/net-misc/netifrc/files/netifrc-0.4.0-interface-types.patch b/net-misc/netifrc/files/netifrc-0.4.0-interface-types.patch
new file mode 100644
index 000000000000..5f00dc1bb101
--- /dev/null
+++ b/net-misc/netifrc/files/netifrc-0.4.0-interface-types.patch
@@ -0,0 +1,26 @@
+From 18dd0598b29d2158529466f1e7097bf894e584dc Mon Sep 17 00:00:00 2001
+From: Andrey Volkov <volkov.am@ekb-info.ru>
+Date: Fri, 15 Jul 2016 13:23:56 +0500
+Subject: Fix missing interface types
+
+(cherry picked from commit c8fe42141c95f5446dabf5c0b1f049151e51c2ad)
+---
+ net/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/net/Makefile b/net/Makefile
+index a03c171..ce73c1e 100644
+--- a/net/Makefile
++++ b/net/Makefile
+@@ -13,7 +13,7 @@ SRCS-Linux= iwconfig.sh.in udhcpc.sh.in
+ INC-Linux= adsl.sh apipa.sh arping.sh bonding.sh br2684ctl.sh bridge.sh \
+ ccwgroup.sh clip.sh ethtool.sh iproute2.sh ifplugd.sh ip6to4.sh \
+ ipppd.sh iwconfig.sh netplugd.sh pppd.sh pump.sh tuntap.sh udhcpc.sh \
+- vlan.sh macvlan.sh ip6rd.sh firewalld.sh
++ vlan.sh macvlan.sh ip6rd.sh firewalld.sh dummy.sh hsr.sh l2tp.sh
+
+ SRCS-NetBSD= ifwatchd.sh.in
+ INC-NetBSD= ifwatchd.sh
+--
+cgit v0.12
+
diff --git a/net-misc/netifrc/netifrc-0.4.0-r1.ebuild b/net-misc/netifrc/netifrc-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..b86adf9a7a18
--- /dev/null
+++ b/net-misc/netifrc/netifrc-0.4.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils systemd udev
+
+DESCRIPTION="Gentoo Network Interface Management Scripts"
+HOMEPAGE="https://www.gentoo.org/proj/en/base/openrc/"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+ #EGIT_REPO_URI="git://github.com/gentoo/netifrc" # Alternate
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~robbat2/distfiles/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="kernel_linux? ( virtual/pkgconfig )
+ !<sys-fs/udev-172"
+RDEPEND="sys-apps/gentoo-functions"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ local ver="git-${EGIT_VERSION:0:6}"
+ sed -i "/^GITVER[[:space:]]*=/s:=.*:=${ver}:" mk/git.mk || die
+ einfo "Producing ChangeLog from Git history"
+ GIT_DIR="${S}/.git" git log >"${S}"/ChangeLog
+ fi
+
+ epatch "${FILESDIR}"/${P}-interface-types.patch #588872
+
+ # Allow user patches to be applied without modifying the ebuild
+ epatch_user
+}
+
+src_compile() {
+ MAKE_ARGS="${MAKE_ARGS}
+ UDEVDIR=${EPREFIX}$(get_udevdir)
+ LIBEXECDIR=${EPREFIX}/lib/${PN} PF=${PF}"
+
+ use prefix && MAKE_ARGS="${MAKE_ARGS} MKPREFIX=yes PREFIX=${EPREFIX}"
+
+ emake ${MAKE_ARGS} all
+}
+
+src_install() {
+ emake ${MAKE_ARGS} DESTDIR="${D}" install
+ dodoc README CREDITS FEATURE-REMOVAL-SCHEDULE STYLE TODO ChangeLog
+
+ # Install the service file
+ LIBEXECDIR=${EPREFIX}/lib/${PN}
+ UNIT_DIR="$(systemd_get_unitdir)"
+ sed "s:@LIBEXECDIR@:${LIBEXECDIR}:" "${S}/systemd/net_at.service.in" > "${T}/net_at.service" || die
+ systemd_newunit "${T}/net_at.service" 'net@.service'
+ dosym "${UNIT_DIR#${EPREFIX}}/net@.service" "${UNIT_DIR#${EPREFIX}}/net@lo.service"
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}"/etc/conf.d/net && -z $REPLACING_VERSIONS ]]; then
+ elog "The network configuration scripts will use dhcp by"
+ elog "default to set up your interfaces."
+ elog "If you need to set up something more complete, see"
+ elog "${EROOT}/usr/share/doc/${P}/README"
+ fi
+}