summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2017-03-05 04:16:46 +0200
committerMichał Górny <mgorny@gentoo.org>2017-03-05 15:37:36 +0100
commitd377f979b7ff6cbb1185dc02b18b4770eff56a3f (patch)
tree0dee446fa643acd2422048dfefaa823a29a8f37a /net-misc
parentkde-frameworks/baloo: Set USE +minimal by default (diff)
downloadgentoo-d377f979b7ff6cbb1185dc02b18b4770eff56a3f.tar.gz
gentoo-d377f979b7ff6cbb1185dc02b18b4770eff56a3f.tar.bz2
gentoo-d377f979b7ff6cbb1185dc02b18b4770eff56a3f.zip
net-misc/streamlink: update live ebuild
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild24
1 files changed, 18 insertions, 6 deletions
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index 29a7bb91187e..a39d95ab8114 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE='xml(+),threads(+)'
inherit distutils-r1 git-r3
@@ -12,18 +13,29 @@ HOMEPAGE="https://streamlink.github.io/"
EGIT_REPO_URI="https://github.com/${PN}/${PN}"
KEYWORDS=""
-LICENSE="BSD-2"
+LICENSE="BSD-2 MIT"
SLOT="0"
IUSE="doc test"
-RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]
virtual/python-singledispatch[${PYTHON_USEDEP}]
- media-video/rtmpdump"
+ dev-python/backports-shutil_which[$(python_gen_usedep 'python2*')]
+ dev-python/backports-shutil_get_terminal_size[$(python_gen_usedep 'python2*')]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ media-video/rtmpdump
+ virtual/ffmpeg"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND} )"
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[$(python_gen_usedep 'python2*')]
+ ${RDEPEND} )"
+
+python_configure_all() {
+ # Avoid iso-639, iso3166 dependencies since we use pycountry.
+ export STREAMLINK_USE_PYCOUNTRY=1
+}
python_compile_all() {
use doc && emake -C docs html