summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-13 15:32:09 +0100
committerSam James <sam@gentoo.org>2022-09-13 15:32:09 +0100
commitd9be9452dc264ba3a32ed16ae97707167df383d4 (patch)
tree173e6966086b968e709ea58c20ec2f22a32ec523 /net-misc
parentnet-misc/suite3270: add 4.2_p5 (diff)
downloadgentoo-d9be9452dc264ba3a32ed16ae97707167df383d4.tar.gz
gentoo-d9be9452dc264ba3a32ed16ae97707167df383d4.tar.bz2
gentoo-d9be9452dc264ba3a32ed16ae97707167df383d4.zip
net-misc/radvd: update EAPI 7 -> 8; fix runtime w/ musl (and build w/ Clang 15)
Bug: https://github.com/radvd-project/radvd/issues/158 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/radvd/files/radvd-2.19-musl-include.patch28
-rw-r--r--net-misc/radvd/radvd-2.19-r3.ebuild69
2 files changed, 97 insertions, 0 deletions
diff --git a/net-misc/radvd/files/radvd-2.19-musl-include.patch b/net-misc/radvd/files/radvd-2.19-musl-include.patch
new file mode 100644
index 000000000000..cba7666f8129
--- /dev/null
+++ b/net-misc/radvd/files/radvd-2.19-musl-include.patch
@@ -0,0 +1,28 @@
+https://github.com/radvd-project/radvd/commit/06689f8c06f44c7e87f7ff1d814428f88375b53f
+https://github.com/radvd-project/radvd/pull/161
+https://github.com/radvd-project/radvd/issues/158
+
+From: Jonathan Davies <jpds@protonmail.com>
+Date: Thu, 25 Nov 2021 15:29:18 +0000
+Subject: [PATCH] Reverts the include.h change in
+ 46883f8a1a02fe42040dd8e48aec0ed871545d4d
+
+Closes: #158
+
+Signed-off-by: Jonathan Davies <jpds@protonmail.com>
+--- a/includes.h
++++ b/includes.h
+@@ -76,12 +76,7 @@
+ #include <sys/sysctl.h>
+ #endif
+
+-#if !defined(__GLIBC__) && defined(linux)
+-#include <linux/if.h>
+-#define IF_NAMESIZE IFNAMSIZ
+-#else
+ #include <net/if.h>
+-#endif
+
+ #ifdef HAVE_NET_IF_DL_H
+ #include <net/if_dl.h>
+
diff --git a/net-misc/radvd/radvd-2.19-r3.ebuild b/net-misc/radvd/radvd-2.19-r3.ebuild
new file mode 100644
index 000000000000..e5bb868d1b38
--- /dev/null
+++ b/net-misc/radvd/radvd-2.19-r3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1 systemd toolchain-funcs
+
+DESCRIPTION="Linux IPv6 Router Advertisement Daemon"
+HOMEPAGE="https://v6web.litech.org/radvd/"
+SRC_URI="https://v6web.litech.org/radvd/dist/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="selinux test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+CDEPEND="dev-libs/libdaemon"
+DEPEND="
+ ${CDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ test? ( dev-libs/check )
+"
+RDEPEND="
+ ${CDEPEND}
+ acct-group/radvd
+ acct-user/radvd
+ selinux? ( sec-policy/selinux-radvd )
+"
+
+DOCS=( CHANGES README TODO radvd.conf.example )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-musl-include.patch
+)
+
+src_configure() {
+ econf --with-pidfile=/run/radvd/radvd.pid \
+ --with-systemdsystemunitdir=no \
+ $(use_with test check)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc INTRO.html
+
+ newinitd "${FILESDIR}"/${PN}-2.15.init ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf ${PN}
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ readme.gentoo_create_doc
+}
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="Please create a configuration file ${ROOT}/etc/radvd.conf.
+See ${ROOT}/usr/share/doc/${PF} for an example.
+
+grsecurity users should allow a specific group to read /proc
+and add the radvd user to that group, otherwise radvd may
+segfault on startup."