summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-07-22 12:43:03 +0200
committerJeroen Roovers <jer@gentoo.org>2018-07-22 12:43:03 +0200
commitda589d0f51154257be7b2c7865441d88e3e373d9 (patch)
treee81222b3dea0a2bf81aa1a604741a67e574d73b0 /net-misc
parentgames-emulation/dolphin: xgetbv tweak for gcc-8 (diff)
downloadgentoo-da589d0f51154257be7b2c7865441d88e3e373d9.tar.gz
gentoo-da589d0f51154257be7b2c7865441d88e3e373d9.tar.bz2
gentoo-da589d0f51154257be7b2c7865441d88e3e373d9.zip
net-misc/youtube-dl: Version 2018.07.21.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2018.07.21.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index e00f8567592e..226bf895ace5 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2017.11.15.tar.gz 2834012 BLAKE2B fd93e3923f99874be58681a886c09e31ac10063975ab636badf27e59b44743c72cddf05e3a431c49ffd0f7b40f9b005f4d90feff85d4ca889dee80833300b076 SHA512 e10c0d53db7fdfb02610b53f54046c0a9354b305ba05c5d00a43649a283a6449263f66ff56171d52cf18f906c6aeccc25dc48ea708b4b1bb2b8323b937abca96
DIST youtube-dl-2018.07.04.tar.gz 2993980 BLAKE2B 79bef6497c6dd5444608e8d75cffac72a0c1779d234a5537af16cb9e876a086bf7b57981e6e85f5f9504be794e0d6d1c46b3f98b1cae509d864799ce6ce7b03d SHA512 7a67948307d8909c0415635c9c560bdf809b085f1675aa2c4aafa8007b8f420beb6347a56e3fbe61507aca1b42ac932ce75ae46aa2cd62e129fa604cd6ceb6e0
DIST youtube-dl-2018.07.10.tar.gz 3001810 BLAKE2B 4ffd9f678897be476983322921640007962cc307e1b0e095a012fd2840a26864bb1125b4f937ca43ba52134e32b80976b6ad185eb5e0f7523852915f61c1b293 SHA512 4f83bc02002d31bd04d9319d798c1b190b5a357864daca9661bcdeef3f71b258fb9b4b76ae1c19a0901ba5b0e56b834f0124353a4e4e3c6d0554a8f4f967c246
+DIST youtube-dl-2018.07.21.tar.gz 3006144 BLAKE2B 63b0fdf38f9e510b163a1737136956c0d4c497b0e3f78caad01170711c359e2ee9638f6448992ff28760cac60d0496c1572a04939f95d060560bc399d3399a4e SHA512 d0c75b8d651a4c401dd706c3ce86882098a16e9bb3e72b3871b3fe5284a345fc04bf5f7a9165a12af63091660a68a9b81f80a523b2090da3556856d69a81b6bf
diff --git a/net-misc/youtube-dl/youtube-dl-2018.07.21.ebuild b/net-misc/youtube-dl/youtube-dl-2018.07.21.ebuild
new file mode 100644
index 000000000000..37bffad45c8e
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2018.07.21.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies lovehomeporn mofosex myvidster porn91 porncom
+ pornflip pornhd pornotube pornovoisines pornoxo ruleporn sexu
+ slutload spankbang spankwire sunporno thisav vporn watchindianporn
+ xbef xnxx xtube xvideos xxxymovies youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber fourtube motherless pornhub redtube tnaflix tube8 xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ eapply_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+}