summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@riseup.net>2021-07-06 11:05:39 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-07-06 05:18:49 -0400
commite0ecef1033d8515af06250124672f586efce40ac (patch)
tree8ec76ddb20fb30acef6a003eefdce59d28d636f4 /net-misc
parentnet-misc/gallery-dl: drop old 1.17.3 and 1.17.4 (diff)
downloadgentoo-e0ecef1033d8515af06250124672f586efce40ac.tar.gz
gentoo-e0ecef1033d8515af06250124672f586efce40ac.tar.bz2
gentoo-e0ecef1033d8515af06250124672f586efce40ac.zip
net-misc/gallery-dl: sync live
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/21111 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gallery-dl/gallery-dl-9999.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/net-misc/gallery-dl/gallery-dl-9999.ebuild b/net-misc/gallery-dl/gallery-dl-9999.ebuild
index c0680f91535c..fec914ad2ced 100644
--- a/net-misc/gallery-dl/gallery-dl-9999.ebuild
+++ b/net-misc/gallery-dl/gallery-dl-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=(python3_{7..9})
+PYTHON_COMPAT=(python3_{8,9})
PYTHON_REQ_USE="sqlite,ssl,xml"
DISTUTILS_USE_SETUPTOOLS=rdepend
@@ -12,7 +12,7 @@ inherit distutils-r1 optfeature
DESCRIPTION="Download image galleries and collections from several image hosting sites"
HOMEPAGE="https://github.com/mikf/gallery-dl"
-if [[ ${PV} == *9999 ]]; then
+if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
else
@@ -20,19 +20,18 @@ else
KEYWORDS="~amd64"
fi
-# tests require network access
-RESTRICT="test"
LICENSE="GPL-2"
SLOT="0"
+# tests require network access
+RESTRICT="test"
RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
distutils_enable_tests setup.py
src_compile() {
- emake data/completion/gallery-dl
- emake data/completion/_gallery-dl
- emake man
+ emake data/completion/{,_}gallery-dl man
+
distutils-r1_src_compile
}