summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-01-19 20:11:13 +0200
committerMart Raudsepp <leio@gentoo.org>2020-01-19 20:16:37 +0200
commited2fca4fb05d646c267706abc9a298143e44c844 (patch)
tree0d2a849d850d9070e65578b1cdae036fd8ad10de /net-misc
parentnet-misc/streamlink: allow python:3.7 (diff)
downloadgentoo-ed2fca4fb05d646c267706abc9a298143e44c844.tar.gz
gentoo-ed2fca4fb05d646c267706abc9a298143e44c844.tar.bz2
gentoo-ed2fca4fb05d646c267706abc9a298143e44c844.zip
net-misc/streamlink: port to EAPI-7
Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index c11c5094f8cf..3460a867236b 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
@@ -28,7 +28,7 @@ IUSE="doc test"
RESTRICT="!test? ( test )"
# >=urllib3-1.23 only needed for python2, but requests pulls some version anyways, so we might as well guarantee at least that ver for py3 too
-RDEPEND="
+DEPEND="
virtual/python-futures[${PYTHON_USEDEP}]
virtual/python-singledispatch[${PYTHON_USEDEP}]
>dev-python/requests-2.21.0[${PYTHON_USEDEP}]
@@ -38,7 +38,11 @@ RDEPEND="
dev-python/pycountry[${PYTHON_USEDEP}]
>=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
+RDEPEND="${DEPEND}
+ media-video/rtmpdump
+ virtual/ffmpeg
+"
+BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
@@ -51,10 +55,6 @@ DEPEND="${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/freezegun[${PYTHON_USEDEP}]
)"
-RDEPEND="${RDEPEND}
- media-video/rtmpdump
- virtual/ffmpeg
-"
python_configure_all() {
# Avoid iso-639, iso3166 dependencies since we use pycountry.