summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-03-30 16:01:04 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-03-30 16:01:42 +0200
commitee2ab60281a0d3fef627fc2f341f4aa385f4c35b (patch)
tree04407947bb074391201e8685e6973f8cb9911009 /net-misc
parentdev-libs/libressl: version 2.6.4 stable on amd64 and x86, bug #651564 (diff)
downloadgentoo-ee2ab60281a0d3fef627fc2f341f4aa385f4c35b.tar.gz
gentoo-ee2ab60281a0d3fef627fc2f341f4aa385f4c35b.tar.bz2
gentoo-ee2ab60281a0d3fef627fc2f341f4aa385f4c35b.zip
net-misc/casync: Add missing dependencies
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/casync/casync-2_p20180321-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/casync/casync-2_p20180321-r1.ebuild b/net-misc/casync/casync-2_p20180321-r1.ebuild
new file mode 100644
index 000000000000..2e1338a68f79
--- /dev/null
+++ b/net-misc/casync/casync-2_p20180321-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot meson
+
+COMMIT="a755da21d3ba5d9cbb002dfc86a3ab0d46b82176"
+DESCRIPTION=" Content-Addressable Data Synchronization Tool"
+HOMEPAGE="https://github.com/systemd/casync"
+SRC_URI="https://github.com/systemd/casync/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+fuse +udev man selinux test"
+
+RDEPEND="
+ app-arch/xz-utils
+ app-arch/zstd
+ dev-libs/openssl:0
+ net-misc/curl
+ virtual/acl
+ fuse? ( sys-fs/fuse:0 )
+ selinux? ( sys-libs/libselinux )
+ udev? ( virtual/libudev )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ man? ( dev-python/sphinx )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dfuse="$(usex fuse true false)"
+ -Dman="$(usex man true false)"
+ -Dselinux="$(usex selinux true false)"
+ -Dtests="$(usex test true false)"
+ -Dudev="$(usex udev true false)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}