summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@riseup.net>2021-05-03 18:31:36 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-05-30 11:08:39 +0300
commitf36992d87325a47cd1d8273e504a5dda7844d393 (patch)
tree374afe9b3481fa41b4236a79f71b311b42869410 /net-misc
parentdev-vcs/hg-evolve: version bumps (diff)
downloadgentoo-f36992d87325a47cd1d8273e504a5dda7844d393.tar.gz
gentoo-f36992d87325a47cd1d8273e504a5dda7844d393.tar.bz2
gentoo-f36992d87325a47cd1d8273e504a5dda7844d393.zip
net-misc/gallery-dl: bump to 1.17.3
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.17.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index badcfd81c0d5..a4e8e061bc36 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1,2 +1,3 @@
DIST gallery-dl-1.17.1.tar.gz 344091 BLAKE2B e5a108d088083e3aa1881919e74f6631321312a225c0dd6d9c6cbee87ecc957d19a6c3812d3f0c80c5937089d1402ca2e0a779c23537f28ab78ad9654c06852d SHA512 015346cec09ab85fa408b3faa6b63d61fa1f2004b39b45d36741cb63e2809c62c48b544c57b0a02b797db6f36cc66172e9c120ff6cf1bf1a2c3d6f05f7ceb627
DIST gallery-dl-1.17.2.tar.gz 347680 BLAKE2B 443d859a6cf45cc36eb03dfd591f5f512f4ac7128aeb6da7530c3758c813023a08c324c6ecf0d8cd6a7db597c1b147dc6dad744af38374a3a9f80e9d9a556746 SHA512 1b62f0607f2a153909029672ecf91ec25a0e5473e8ec2c9974ff3a1a03e99a94616565c5092035cbd34865606f4ee9bbb8cf1949f5792f6edb07b7eeaa5dab51
+DIST gallery-dl-1.17.3.tar.gz 353605 BLAKE2B bae09e7a71457510c5d05c897e0082a6dca1b9c9a0a7bb57cd4585fd3a3748af7dd9c85cd92340fe3fb8329562c7153af717ef07d7c0a4a486a3400d37869031 SHA512 ee11058f04197695a2a47b50a9bef81f91b10875959841bca0f9ae27d9229b9ce1fa1e6fd32b7199163d458d698ccd92be7a700aeaed55078feaf70063883f47
diff --git a/net-misc/gallery-dl/gallery-dl-1.17.3.ebuild b/net-misc/gallery-dl/gallery-dl-1.17.3.ebuild
new file mode 100644
index 000000000000..c0680f91535c
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.17.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7..9})
+PYTHON_REQ_USE="sqlite,ssl,xml"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# tests require network access
+RESTRICT="test"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+src_compile() {
+ emake data/completion/gallery-dl
+ emake data/completion/_gallery-dl
+ emake man
+ distutils-r1_src_compile
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}