summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-12-28 20:44:42 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-12-28 20:44:51 +0100
commitf4c9b12f0e1a55518a0e9a23279f67068724339e (patch)
treee60399382dac28d18353b16f29e23e1170730d87 /net-misc
parentnet-misc/dhcpcd: Removed old (diff)
downloadgentoo-f4c9b12f0e1a55518a0e9a23279f67068724339e.tar.gz
gentoo-f4c9b12f0e1a55518a0e9a23279f67068724339e.tar.bz2
gentoo-f4c9b12f0e1a55518a0e9a23279f67068724339e.zip
net-misc/dhcpcd-ui: Bump to version 0.7.8
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd-ui/Manifest1
-rw-r--r--net-misc/dhcpcd-ui/dhcpcd-ui-0.7.8.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/dhcpcd-ui/Manifest b/net-misc/dhcpcd-ui/Manifest
index 5c934d209085..4c40350edfc6 100644
--- a/net-misc/dhcpcd-ui/Manifest
+++ b/net-misc/dhcpcd-ui/Manifest
@@ -1 +1,2 @@
DIST dhcpcd-ui-0.7.7.tar.xz 195648 BLAKE2B f382e331326e66d81674579ba018e6f9a6662df9d10fa0cca92808290e5d7621e7861afaa3d9a2c4d05fcc24b619922f8740faeaf4a531701f5d14505636fdf7 SHA512 46f66c16986c248740b2dc8ce0edb663fbd35809d2d21f701588c3736cdafb32b04c57ffbc6f8974841499ab46f6a1084d0a761b290e9d02ea3a9fae36a0ff3d
+DIST dhcpcd-ui-0.7.8.tar.xz 135028 BLAKE2B f3e79bb00708e2ce2ebb93d917506bb0fb015071b415768c47979d7f2b5e35d6f22bf71a58c43989dedc6561f0a8be738824f06627d2fa0995e335d7ef1925cd SHA512 5f0d2c32c32fc141feca0ab43a531d9b4f45e071a8a1e3ee1923d6394a3e5d6322e6f7e607b91154af4cfee93d649164c7ed3b805731dfc242c3ac367ec156c4
diff --git a/net-misc/dhcpcd-ui/dhcpcd-ui-0.7.8.ebuild b/net-misc/dhcpcd-ui/dhcpcd-ui-0.7.8.ebuild
new file mode 100644
index 000000000000..6878e53ae1ac
--- /dev/null
+++ b/net-misc/dhcpcd-ui/dhcpcd-ui-0.7.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd xdg
+
+DESCRIPTION="Desktop notification and configuration for dhcpcd"
+HOMEPAGE="https://roy.marples.name/projects/dhcpcd-ui/"
+SRC_URI="https://roy.marples.name/downloads/${PN%-ui}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gtk gtk2 libnotify ncurses qt5"
+
+REQUIRED_USE="libnotify? ( gtk )
+ qt5? ( !libnotify )"
+
+BDEPEND="
+ virtual/libintl
+"
+DEPEND="
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ gtk2? (
+ x11-libs/gtk+:2
+ )
+ !gtk2? (
+ x11-libs/gtk+:3
+ )
+ )
+ libnotify? ( x11-libs/libnotify )
+ ncurses? ( sys-libs/ncurses:0= )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/mesa
+ )
+"
+
+RDEPEND="${DEPEND}
+ >=net-misc/dhcpcd-6.4.4"
+
+src_configure() {
+ local myeconfargs=(
+ --without-qt
+ $(use_enable debug)
+ $(use_enable libnotify notification)
+ $(use_with gtk gtk $(usex gtk2 'gtk+-2.0' 'gtk+-3.0'))
+ $(use_with ncurses curses)
+ $(use_with qt5 qt)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+ systemd_dounit src/dhcpcd-online/dhcpcd-wait-online.service
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}