summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-12-27 20:34:48 +0100
committerIonen Wolkens <ionen@gentoo.org>2022-01-04 04:05:58 -0500
commitfc777e406a5214ff5c5cd483b9b66bf60aed4091 (patch)
treeef5a1f0319dc94bfcbcfc9e43a2cd17a65d25158 /net-misc
parentmedia-sound/yoshimi: Stabilize 2.1.2.2 amd64, #830577 (diff)
downloadgentoo-fc777e406a5214ff5c5cd483b9b66bf60aed4091.tar.gz
gentoo-fc777e406a5214ff5c5cd483b9b66bf60aed4091.tar.bz2
gentoo-fc777e406a5214ff5c5cd483b9b66bf60aed4091.zip
net-misc/gns3-server: version bump (2.2.28)
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gns3-server/Manifest1
-rw-r--r--net-misc/gns3-server/gns3-server-2.2.28.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/gns3-server/Manifest b/net-misc/gns3-server/Manifest
index 60149d0c7250..8ce419c914a4 100644
--- a/net-misc/gns3-server/Manifest
+++ b/net-misc/gns3-server/Manifest
@@ -1,2 +1,3 @@
DIST gns3-server-2.2.25.tar.gz 10229566 BLAKE2B 73827940698335dcf9ef6d4b6c4c88b162852ec493f8ea05eebbdca20df3c84e4f5ee2ac218ed72755350df2f0e27cfc6cbd34b541e9e5bc0eada2fcb8e266ac SHA512 c7fa163eedc064fd266100658d7d2084ab0c542280d6689938a06943534df320f905c0e46175580bd3792218369936c55f9e135a12577f8a4b7eb86ac8fe9739
DIST gns3-server-2.2.26.tar.gz 10230386 BLAKE2B 9b9de96cc22aeb1da92a48c9c04a0bf0271f3e47909bf09de76f357d727a4dfc2aa8181c47713192a9c88e55497ca3d8577f34635bf1f2f353387008c1bd13b7 SHA512 80a3e2939374b7a8f7e961f565b16d8a7575414793a3772235b41eadc184d02543ddae18122e90a2602ca51ce24513e1add17b1e7732f44c108daf3d6bc9dc7a
+DIST gns3-server-2.2.28.tar.gz 10240577 BLAKE2B 760f4f534ef6c4c94a62bb89a19fa2f300ac3f613b69eb6b6d3cfd5d08a13673f8133a7fb4e66e4fd3cf79b8c2988157038855d523af444a434865f40a8a0e38 SHA512 d75a510050dcb9bdf9f6bb2336c797768c6f6451a49a87143e977a2ba1a39f5a062702bbd0fd2cd750fdc24092a3d4e3defa3d4a2411e7b6a0df3e284c6fd512
diff --git a/net-misc/gns3-server/gns3-server-2.2.28.ebuild b/net-misc/gns3-server/gns3-server-2.2.28.ebuild
new file mode 100644
index 000000000000..af4f9ccadcd5
--- /dev/null
+++ b/net-misc/gns3-server/gns3-server-2.2.28.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature systemd
+
+DESCRIPTION="GNS3 server to asynchronously manage emulators"
+HOMEPAGE="https://www.gns3.com/ https://github.com/GNS3/gns3-server"
+SRC_URI="https://github.com/GNS3/gns3-server/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-emulation/dynamips
+ >=dev-python/aiofiles-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-3.7.4[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-cors-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/async_timeout-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.7.0[${PYTHON_USEDEP}]
+ >=dev-python/py-cpuinfo-8.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sentry-sdk-1.3.1[${PYTHON_USEDEP}]
+ net-misc/ubridge
+ sys-apps/busybox
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ # newer python packages are fine
+ sed -i -e 's/[<>=].*//' requirements.txt || die
+
+ # Remove Pre-built busybox binary
+ rm gns3server/compute/docker/resources/bin/busybox || die
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ systemd_dounit init/gns3.service.systemd
+
+ mkdir -p "${D}$(python_get_sitedir)/gns3server/compute/docker/resources/bin" || die
+ ln -s /bin/busybox "${D}$(python_get_sitedir)/gns3server/compute/docker/resources/bin/busybox" || die
+}
+
+pkg_postinst() {
+ elog "net-misc/gns3-server has several optional packages that must be merged manually for additional functionality."
+ elog ""
+ optfeature "QEMU Support" "app-emulation/qemu"
+ optfeature "Virtualbox Support" "app-emulation/virtualbox"
+ optfeature "Docker Support" "app-containers/docker"
+ optfeature "Wireshark Support" "net-analyzer/wireshark"
+ elog ""
+ elog "The following packages are currently unsupported:"
+ elog "iouyap and vpcs"
+}