summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-12-10 22:34:44 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2019-12-10 22:34:56 +0100
commitfe2483694a02a15acd312e10cbc84a5315adb3f8 (patch)
tree57fc1bfe886199f7f43495c3648b52dc931e20b3 /net-misc
parentmedia-video/orion: use xdg eclass (diff)
downloadgentoo-fe2483694a02a15acd312e10cbc84a5315adb3f8.tar.gz
gentoo-fe2483694a02a15acd312e10cbc84a5315adb3f8.tar.bz2
gentoo-fe2483694a02a15acd312e10cbc84a5315adb3f8.zip
net-misc/x2goserver: use xdg eclass
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/x2goserver/x2goserver-4.1.0.2.ebuild11
-rw-r--r--net-misc/x2goserver/x2goserver-4.1.0.3.ebuild11
2 files changed, 4 insertions, 18 deletions
diff --git a/net-misc/x2goserver/x2goserver-4.1.0.2.ebuild b/net-misc/x2goserver/x2goserver-4.1.0.2.ebuild
index 62fa686aadcd..63bc43289678 100644
--- a/net-misc/x2goserver/x2goserver-4.1.0.2.ebuild
+++ b/net-misc/x2goserver/x2goserver-4.1.0.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit multilib systemd toolchain-funcs user xdg-utils
+inherit multilib systemd toolchain-funcs user xdg
DESCRIPTION="The X2Go server"
HOMEPAGE="http://www.x2go.org"
@@ -81,6 +81,7 @@ src_install() {
}
pkg_postinst() {
+ xdg_pkg_postinst
if use sqlite ; then
if [[ -f "${EROOT}"/var/lib/x2go/x2go_sessions ]] ; then
elog "To use sqlite and update your existing database, run:"
@@ -99,12 +100,4 @@ pkg_postinst() {
elog "For password authentication, you need to enable PasswordAuthentication"
elog "in /etc/ssh/sshd_config (disabled by default in Gentoo)"
elog "An init script was installed for x2gocleansessions"
-
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
}
diff --git a/net-misc/x2goserver/x2goserver-4.1.0.3.ebuild b/net-misc/x2goserver/x2goserver-4.1.0.3.ebuild
index 710f925aa268..01bc3f6c2225 100644
--- a/net-misc/x2goserver/x2goserver-4.1.0.3.ebuild
+++ b/net-misc/x2goserver/x2goserver-4.1.0.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib systemd toolchain-funcs user xdg-utils
+inherit multilib systemd toolchain-funcs user xdg
DESCRIPTION="The X2Go server"
HOMEPAGE="http://www.x2go.org"
@@ -84,6 +84,7 @@ src_install() {
}
pkg_postinst() {
+ xdg_pkg_postinst
if use sqlite ; then
if [[ -f "${EROOT}"/var/lib/x2go/x2go_sessions ]] ; then
elog "To use sqlite and update your existing database, run:"
@@ -102,12 +103,4 @@ pkg_postinst() {
elog "For password authentication, you need to enable PasswordAuthentication"
elog "in /etc/ssh/sshd_config (disabled by default in Gentoo)"
elog "An init script was installed for x2gocleansessions"
-
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
}