summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-01-16 12:36:43 -0500
committerMike Gilbert <floppym@gentoo.org>2022-01-16 12:37:05 -0500
commitff759fb1a6d3797f6bc1cdc1aeb284aa59e9990d (patch)
tree56fb908dc01e36373f2c9a6894ca5d916aa9b3e7 /net-misc
parentnet-misc/wget: replace 'cookie_check' with 'cookie-check' (diff)
downloadgentoo-ff759fb1a6d3797f6bc1cdc1aeb284aa59e9990d.tar.gz
gentoo-ff759fb1a6d3797f6bc1cdc1aeb284aa59e9990d.tar.bz2
gentoo-ff759fb1a6d3797f6bc1cdc1aeb284aa59e9990d.zip
net-misc/wget: drop 1.21.1
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wget/Manifest1
-rw-r--r--net-misc/wget/wget-1.21.1.ebuild127
2 files changed, 0 insertions, 128 deletions
diff --git a/net-misc/wget/Manifest b/net-misc/wget/Manifest
index 4f427713655a..f50cdd974355 100644
--- a/net-misc/wget/Manifest
+++ b/net-misc/wget/Manifest
@@ -1,2 +1 @@
-DIST wget-1.21.1.tar.gz 4884887 BLAKE2B 28a3044f33df1d24e13900e8018a38cabae21fb41dd2e089bdbfd759b4adee3771ab558b84f5a8b6f546bc84a3387c973903f9fe06562093d3566e22d1528587 SHA512 784efbf9fe43a1671109e32a9c36237eb2d5c19cf756bf6f6e65517fb21464d3d94b1d6f491852d23b3ddff63e38fe6b60df9125c91b139993af59875e3a0712
DIST wget-1.21.2.tar.gz 5004576 BLAKE2B e11c3a2b89ab26834dc4cbb445bcc6122d3a6b2a5b9c6de1ce9e8f062281f9e5aa1f80ca37a44791ba5aaf6a447015a26afef2199cdb75f1931d5e1ffb1f406b SHA512 3e35f92604486ca459f26df97d392579f1d83a9254519e8ce249b410bacf70dddf716d6caa3b29fd4865163f60410b2b8ad1ca1f7bb3dbb2456386b7647b988d
diff --git a/net-misc/wget/wget-1.21.1.ebuild b/net-misc/wget/wget-1.21.1.ebuild
deleted file mode 100644
index dddab922bcfd..000000000000
--- a/net-misc/wget/wget-1.21.1.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit flag-o-matic python-any-r1 toolchain-funcs
-
-DESCRIPTION="Network utility to retrieve files from the WWW"
-HOMEPAGE="https://www.gnu.org/software/wget/"
-SRC_URI="mirror://gnu/wget/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="cookie-check debug gnutls idn ipv6 metalink nls ntlm pcre +ssl static test uuid zlib"
-REQUIRED_USE=" ntlm? ( !gnutls ssl ) gnutls? ( ssl )"
-RESTRICT="!test? ( test )"
-
-# Force a newer libidn2 to avoid libunistring deps. #612498
-LIB_DEPEND="
- cookie-check? ( net-libs/libpsl )
- idn? ( >=net-dns/libidn2-0.14:=[static-libs(+)] )
- metalink? ( media-libs/libmetalink )
- pcre? ( dev-libs/libpcre2[static-libs(+)] )
- ssl? (
- gnutls? ( net-libs/gnutls:0=[static-libs(+)] )
- !gnutls? ( dev-libs/openssl:0=[static-libs(+)] )
- )
- uuid? ( sys-apps/util-linux[static-libs(+)] )
- zlib? ( sys-libs/zlib[static-libs(+)] )
-"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="
- ${RDEPEND}
- static? ( ${LIB_DEPEND} )
- test? (
- ${PYTHON_DEPS}
- dev-lang/perl
- dev-perl/HTTP-Daemon
- dev-perl/HTTP-Message
- dev-perl/IO-Socket-SSL
- )
-"
-BDEPEND="
- app-arch/xz-utils
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-
-DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # revert some hack that breaks linking, bug #585924
- if [[ ${CHOST} == *-darwin* ]] \
- || [[ ${CHOST} == *-solaris* ]] \
- || [[ ${CHOST} == *-cygwin* ]] \
- ; then
- sed -i \
- -e 's/^ LIBICONV=$/:/' \
- configure || die
- fi
-}
-
-src_configure() {
- # fix compilation on Solaris, we need filio.h for FIONBIO as used in
- # the included gnutls -- force ioctl.h to include this header
- [[ ${CHOST} == *-solaris* ]] && append-cppflags -DBSD_COMP=1
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00050.html
- # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00051.html
- append-cppflags '-D__nonnull\(X\)='
- fi
-
- if use static ; then
- append-ldflags -static
- tc-export PKG_CONFIG
- PKG_CONFIG+=" --static"
- fi
-
- # There is no flag that controls this. libunistring-prefix only
- # controls the search path (which is why we turn it off below).
- # Further, libunistring is only needed w/older libidn2 installs,
- # and since we force the latest, we can force off libunistring. #612498
- local myeconfargs=(
- --disable-assert
- --disable-pcre
- --disable-rpath
- --without-included-libunistring
- --without-libunistring-prefix
- $(use_enable debug)
- $(use_enable idn iri)
- $(use_enable ipv6)
- $(use_enable nls)
- $(use_enable ntlm)
- $(use_enable pcre pcre2)
- $(use_enable ssl digest)
- $(use_enable ssl opie)
- $(use_with cookie-check libpsl)
- $(use_with idn libidn)
- $(use_with metalink)
- $(use_with ssl ssl $(usex gnutls gnutls openssl))
- $(use_with uuid libuuid)
- $(use_with zlib)
- )
- ac_cv_libunistring=no \
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- sed -i \
- -e "s:/usr/local/etc:${EPREFIX}/etc:g" \
- "${ED}"/etc/wgetrc \
- "${ED}"/usr/share/man/man1/wget.1 \
- "${ED}"/usr/share/info/wget.info \
- || die
-}