summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-11-09 23:58:53 -0500
committerMike Frysinger <vapier@gentoo.org>2016-11-09 23:58:53 -0500
commit007731c32667ec22df59d8173b8b019229acb533 (patch)
tree77c00ce38c84b161e8ce249315bba073b00019a8 /net-nds/openldap/openldap-2.4.40-r4.ebuild
parentnet-nds/openldap: skip acct creation for USE=minimal (diff)
downloadgentoo-007731c32667ec22df59d8173b8b019229acb533.tar.gz
gentoo-007731c32667ec22df59d8173b8b019229acb533.tar.bz2
gentoo-007731c32667ec22df59d8173b8b019229acb533.zip
net-nds/openldap: fix cross-compiling due to pthread tests #463966
Diffstat (limited to 'net-nds/openldap/openldap-2.4.40-r4.ebuild')
-rw-r--r--net-nds/openldap/openldap-2.4.40-r4.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/net-nds/openldap/openldap-2.4.40-r4.ebuild b/net-nds/openldap/openldap-2.4.40-r4.ebuild
index b12340ef2bbe..26c2ac18c749 100644
--- a/net-nds/openldap/openldap-2.4.40-r4.ebuild
+++ b/net-nds/openldap/openldap-2.4.40-r4.ebuild
@@ -472,6 +472,11 @@ multilib_src_configure() {
$(use_enable tcpd wrappers)
)
+ # Some cross-compiling tests don't pan out well.
+ tc-is-cross-compiler && myconf+=(
+ --with-yielding-select=yes
+ )
+
local ssl_lib="no"
if use ssl || ( ! use minimal && use samba ) ; then
ssl_lib="openssl"