summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-19 22:36:37 +0000
committerSam James <sam@gentoo.org>2022-03-19 22:39:04 +0000
commit96fe1038c5e07c43aecac821a9f078abdc612dde (patch)
treecb07e62552a7641a56b8d3af9429e21ac034d7ec /net-nds/openldap
parentnet-nds/openldap: add upstream MAKEOPTS patch (diff)
downloadgentoo-96fe1038c5e07c43aecac821a9f078abdc612dde.tar.gz
gentoo-96fe1038c5e07c43aecac821a9f078abdc612dde.tar.bz2
gentoo-96fe1038c5e07c43aecac821a9f078abdc612dde.zip
net-nds/openldap: fix tc-getCC quoting
Breaks build otherwise for e.g. ABI_X86_32: ``` >>> Compiling source in /var/tmp/portage/net-nds/openldap-2.6.1/work/openldap-OPENLDAP_REL_ENG_2_6_1 ... * abi_x86_32.x86: running multilib-minimal_abi_src_compile make -j32 -l32 CC=x86_64-pc-linux-gnu-gcc -m32 SHELL=/bin/sh make: invalid option -- '3' make: invalid option -- '2' Usage: make [options] [target] ... Options: ``` Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nds/openldap')
-rw-r--r--net-nds/openldap/openldap-2.6.1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/net-nds/openldap/openldap-2.6.1.ebuild b/net-nds/openldap/openldap-2.6.1.ebuild
index 0e0449e3885e..04bd86b1b15b 100644
--- a/net-nds/openldap/openldap-2.6.1.ebuild
+++ b/net-nds/openldap/openldap-2.6.1.ebuild
@@ -144,7 +144,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.6.1-cloak.patch
"${FILESDIR}"/${PN}-2.6.1-flags.patch
"${FILESDIR}"/${PN}-2.6.1-fix-missing-mapping.patch
- "${FILESDIR}"/${PN}-2.6.1-make-flags.patch
)
openldap_filecount() {
@@ -515,7 +514,7 @@ src_configure_cxx() {
multilib_src_compile() {
tc-export AR CC CXX
- emake CC=$(tc-getCC) SHELL="${EPREFIX}"/bin/sh
+ emake CC="$(tc-getCC)" SHELL="${EPREFIX}"/bin/sh
if ! use minimal && multilib_is_native_abi ; then
if use cxx ; then
@@ -554,7 +553,7 @@ multilib_src_compile() {
emake \
LDAP_BUILD="${BUILD_DIR}" \
- CC=$(tc-getCC) libexecdir="${EPREFIX}"/usr/$(get_libdir)/openldap
+ CC="$(tc-getCC)" libexecdir="${EPREFIX}/usr/$(get_libdir)/openldap"
popd &>/dev/null || die
fi
@@ -616,7 +615,7 @@ multilib_src_test() {
}
multilib_src_install() {
- emake CC=$(tc-getCC) \
+ emake CC="$(tc-getCC)" \
DESTDIR="${D}" SHELL="${EPREFIX}"/bin/sh install
if ! use minimal && multilib_is_native_abi; then