summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-11-03 09:53:27 -0500
committerMike Frysinger <vapier@gentoo.org>2015-11-03 10:08:06 -0500
commitde6d02b6cf69bec8e91b7e7e3b4a083f8b13b822 (patch)
tree343b17f8e13cfc59cb882664d23b0341d1cf1efe /net-nds/rpcbind/rpcbind-0.2.3-r1.ebuild
parentnet-libs/libtirpc: version bump to 1.0.1 (diff)
downloadgentoo-de6d02b6cf69bec8e91b7e7e3b4a083f8b13b822.tar.gz
gentoo-de6d02b6cf69bec8e91b7e7e3b4a083f8b13b822.tar.bz2
gentoo-de6d02b6cf69bec8e91b7e7e3b4a083f8b13b822.zip
net-nds/rpcbind: add upstream fix for CVE-2015-7236 #560990
Diffstat (limited to 'net-nds/rpcbind/rpcbind-0.2.3-r1.ebuild')
-rw-r--r--net-nds/rpcbind/rpcbind-0.2.3-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-nds/rpcbind/rpcbind-0.2.3-r1.ebuild b/net-nds/rpcbind/rpcbind-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..937aaaeecc18
--- /dev/null
+++ b/net-nds/rpcbind/rpcbind-0.2.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://linux-nfs.org/~steved/rpcbind.git"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="portmap replacement which supports RPC over various protocols"
+HOMEPAGE="http://sourceforge.net/projects/rpcbind/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="debug selinux systemd tcpd warmstarts"
+
+CDEPEND=">=net-libs/libtirpc-0.2.3:=
+ systemd? ( sys-apps/systemd:= )
+ tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-rpcbind )"
+
+src_prepare() {
+ [[ ${PV} == "9999" ]] && eautoreconf
+ epatch "${FILESDIR}"/${P}-libtirpc.patch
+ epatch "${FILESDIR}"/${P}-mem-corrupt.patch #560990
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ --bindir="${EPREFIX}"/sbin \
+ --with-statedir="${EPREFIX}"/run/${PN} \
+ --with-rpcuser=root \
+ --with-systemdsystemunitdir=$(usex systemd "$(systemd_get_unitdir)" "no") \
+ $(use_enable tcpd libwrap) \
+ $(use_enable debug) \
+ $(use_enable warmstarts)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}