summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-11 23:09:37 -0700
committerMatt Turner <mattst88@gentoo.org>2021-05-11 23:25:19 -0700
commitbe0ca6b40ce62d7ef2b09bf8fccdadf89504d42d (patch)
tree9a75fe8050061807cb3a6d74c9a19ae33adead89 /net-nds/rpcbind
parentnet-nds/rpcbind: Port to EAPI=7 (diff)
downloadgentoo-be0ca6b40ce62d7ef2b09bf8fccdadf89504d42d.tar.gz
gentoo-be0ca6b40ce62d7ef2b09bf8fccdadf89504d42d.tar.bz2
gentoo-be0ca6b40ce62d7ef2b09bf8fccdadf89504d42d.zip
net-nds/rpcbind: Version bump to 1.2.6
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-nds/rpcbind')
-rw-r--r--net-nds/rpcbind/Manifest1
-rw-r--r--net-nds/rpcbind/rpcbind-1.2.6.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-nds/rpcbind/Manifest b/net-nds/rpcbind/Manifest
index 1e114d6b58e5..a64b021db6bb 100644
--- a/net-nds/rpcbind/Manifest
+++ b/net-nds/rpcbind/Manifest
@@ -1 +1,2 @@
DIST rpcbind-1.2.5.tar.bz2 123502 BLAKE2B de0d10406aeffd75195c1fa1d0179b2c7c0ba54c3f3ac58ce9d7e9448d1dbe91a296ad69c45dee115e0a739aa9cfec53b750d3a5ca405e16605a92bbb2006859 SHA512 e884c4757950ccead0f9a07f50625a63e6f18f9bfae9fcfffa3e5fa4b7a66c3a99d9fa303061848fe8211509d5456f24ff26e4579af6e161a35522268f3ef3e4
+DIST rpcbind-1.2.6.tar.bz2 124590 BLAKE2B bb0e9f81e4747f8a732c9e25af561e79f2b6cd1c1955db586833871901b6da73f4b7ef32149a81b75daa81359b9c0554726670460b28857042dd66a2f861cac2 SHA512 fb89c61be4c533fe2e6057749d97079a2d1c9fac0d35d6be1a159a0edbf86092b3fc121f19fa920e75aac5ecdd3f59f5978e6401d5cad16cd438c977736206a7
diff --git a/net-nds/rpcbind/rpcbind-1.2.6.ebuild b/net-nds/rpcbind/rpcbind-1.2.6.ebuild
new file mode 100644
index 000000000000..51778b3ddf63
--- /dev/null
+++ b/net-nds/rpcbind/rpcbind-1.2.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://linux-nfs.org/~steved/rpcbind.git"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="portmap replacement which supports RPC over various protocols"
+HOMEPAGE="https://sourceforge.net/projects/rpcbind/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="debug remotecalls selinux systemd tcpd warmstarts"
+REQUIRED_USE="systemd? ( warmstarts )"
+
+DEPEND=">=net-libs/libtirpc-0.2.3:=
+ systemd? ( sys-apps/systemd:= )
+ tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-rpcbind )"
+BDEPEND="
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/sbin
+ --sbindir="${EPREFIX}"/sbin
+ --with-statedir="${EPREFIX}"/run/${PN}
+ --with-systemdsystemunitdir=$(usex systemd "$(systemd_get_systemunitdir)" "no")
+ $(use_enable debug)
+ $(use_enable remotecalls rmtcalls)
+ $(use_enable warmstarts)
+ $(use_enable tcpd libwrap)
+ )
+
+ # Avoid using rpcsvc headers
+ # https://bugs.gentoo.org/705224
+ export ac_cv_header_rpcsvc_mount_h=no
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}