summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2017-07-18 09:06:20 +0300
committerSergey Popov <pinkbyte@gentoo.org>2017-07-18 09:07:19 +0300
commitc739c498c15102982c8e3b83c836578783b04dc6 (patch)
tree3b8a8cb24aeaa6ed8c913b7c6a3b00ca9fa6d49e /net-nds/shelldap/shelldap-1.4.0.ebuild
parentdev-ruby/hoe: cleanup (diff)
downloadgentoo-c739c498c15102982c8e3b83c836578783b04dc6.tar.gz
gentoo-c739c498c15102982c8e3b83c836578783b04dc6.tar.bz2
gentoo-c739c498c15102982c8e3b83c836578783b04dc6.zip
net-nds/shelldap: version bump, drop old
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'net-nds/shelldap/shelldap-1.4.0.ebuild')
-rw-r--r--net-nds/shelldap/shelldap-1.4.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-nds/shelldap/shelldap-1.4.0.ebuild b/net-nds/shelldap/shelldap-1.4.0.ebuild
new file mode 100644
index 000000000000..904d89c8feb3
--- /dev/null
+++ b/net-nds/shelldap/shelldap-1.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GENTOO_DEPEND_ON_PERL=noslotop
+inherit eutils perl-module
+
+DESCRIPTION="A handy shell-like interface for browsing LDAP servers and editing their content"
+HOMEPAGE="https://bitbucket.org/mahlon/shelldap/"
+SRC_URI="https://bitbucket.org/mahlon/shelldap/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+readline sasl +ssl"
+
+DEPEND=""
+RDEPEND="dev-perl/Algorithm-Diff
+ sasl? ( dev-perl/Authen-SASL )
+ dev-perl/IO-Socket-SSL
+ dev-perl/perl-ldap
+ dev-perl/TermReadKey
+ readline? ( dev-perl/Term-ReadLine-Gnu )
+ dev-perl/Term-Shell
+ dev-perl/YAML-Syck
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long
+ virtual/perl-Digest-MD5"
+
+src_configure() { :; }
+
+src_compile() {
+ pod2man --name "${PN}" < "${PN}" > "${PN}.1" || die 'creating manpage failed'
+}
+
+src_install() {
+ doman "${PN}.1"
+ dobin "${PN}"
+ dodoc USAGE
+}