summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-30 21:25:13 +0000
committerSam James <sam@gentoo.org>2021-03-30 21:45:42 +0000
commit10e80accf8f641cf77cd11546ae8333da3ad80ec (patch)
tree9eccf38c7644cde98f7fb577d8d7e8d8461a08f8 /net-nds/tac_plus/tac_plus-4.0.4.19-r4.ebuild
parentnet-misc/socket: port to EAPI 7, drop base.eclass (diff)
downloadgentoo-10e80accf8f641cf77cd11546ae8333da3ad80ec.tar.gz
gentoo-10e80accf8f641cf77cd11546ae8333da3ad80ec.tar.bz2
gentoo-10e80accf8f641cf77cd11546ae8333da3ad80ec.zip
net-nds/tac_plus: port to EAPI 7, drop base.eclass
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nds/tac_plus/tac_plus-4.0.4.19-r4.ebuild')
-rw-r--r--net-nds/tac_plus/tac_plus-4.0.4.19-r4.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/net-nds/tac_plus/tac_plus-4.0.4.19-r4.ebuild b/net-nds/tac_plus/tac_plus-4.0.4.19-r4.ebuild
index f94caec0a181..5d770f4652e1 100644
--- a/net-nds/tac_plus/tac_plus-4.0.4.19-r4.ebuild
+++ b/net-nds/tac_plus/tac_plus-4.0.4.19-r4.ebuild
@@ -1,36 +1,37 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools base libtool
+inherit autotools
MY_P="tacacs+-F${PV}"
-S="${WORKDIR}/${MY_P}"
-
DESCRIPTION="An updated version of Cisco's TACACS+ server"
HOMEPAGE="http://www.shrubbery.net/tac_plus/"
SRC_URI="ftp://ftp.shrubbery.net/pub/tac_plus/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="HPND RSA GPL-2" # GPL-2 only for init script
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="debug finger maxsess tcpd skey static-libs"
-DEPEND="skey? ( >=sys-auth/skey-1.1.5-r1 )
+DEPEND="
+ sys-libs/pam
+ skey? ( >=sys-auth/skey-1.1.5-r1 )
tcpd? ( sys-apps/tcp-wrappers )
- sys-libs/pam"
+"
RDEPEND="${DEPEND}"
PATCHES=(
-"${FILESDIR}/${P}-parallelmake.patch"
-"${FILESDIR}/${P}-deansification.patch"
+ "${FILESDIR}"/${P}-parallelmake.patch
+ "${FILESDIR}"/${P}-deansification.patch
)
src_prepare() {
- base_src_prepare
+ default
+
AT_M4DIR="." eautoreconf
- elibtoolize
}
src_configure() {
@@ -46,7 +47,10 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install
- use static-libs || find "${D}" -name '*.la' -delete || die "Unable to remove spurious libtool archive"
+ if use static-libs ; then
+ find "${D}" -name '*.la' -delete || die "Unable to remove spurious libtool archive"
+ fi
+
dodoc CHANGES FAQ
newinitd "${FILESDIR}/tac_plus.init2" tac_plus