summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:58:10 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:30:12 +0100
commit70d19ec56b8a00963fdb09b76d51ce608563095f (patch)
tree0b9e1531be58a1cac3d89fd933eadb8e089a6d53 /net-nds
parentnet-misc/stunnel: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-70d19ec56b8a00963fdb09b76d51ce608563095f.tar.gz
gentoo-70d19ec56b8a00963fdb09b76d51ce608563095f.tar.bz2
gentoo-70d19ec56b8a00963fdb09b76d51ce608563095f.zip
net-nds/openldap: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/openldap/openldap-2.4.57-r1.ebuild2
-rw-r--r--net-nds/openldap/openldap-2.4.58-r1.ebuild2
-rw-r--r--net-nds/openldap/openldap-2.4.59-r1.ebuild2
-rw-r--r--net-nds/openldap/openldap-2.5.4.ebuild2
4 files changed, 8 insertions, 0 deletions
diff --git a/net-nds/openldap/openldap-2.4.57-r1.ebuild b/net-nds/openldap/openldap-2.4.57-r1.ebuild
index 7486eb82e4bc..47420777739a 100644
--- a/net-nds/openldap/openldap-2.4.57-r1.ebuild
+++ b/net-nds/openldap/openldap-2.4.57-r1.ebuild
@@ -864,6 +864,8 @@ pkg_preinst() {
pkg_postinst() {
if ! use minimal ; then
+ tmpfiles_process slapd.conf
+
# You cannot build SSL certificates during src_install that will make
# binary packages containing your SSL key, which is both a security risk
# and a misconfiguration if multiple machines use the same key and cert.
diff --git a/net-nds/openldap/openldap-2.4.58-r1.ebuild b/net-nds/openldap/openldap-2.4.58-r1.ebuild
index 633bd5c86de1..679dc8b2ae51 100644
--- a/net-nds/openldap/openldap-2.4.58-r1.ebuild
+++ b/net-nds/openldap/openldap-2.4.58-r1.ebuild
@@ -864,6 +864,8 @@ pkg_preinst() {
pkg_postinst() {
if ! use minimal ; then
+ tmpfiles_process slapd.conf
+
# You cannot build SSL certificates during src_install that will make
# binary packages containing your SSL key, which is both a security risk
# and a misconfiguration if multiple machines use the same key and cert.
diff --git a/net-nds/openldap/openldap-2.4.59-r1.ebuild b/net-nds/openldap/openldap-2.4.59-r1.ebuild
index 633bd5c86de1..679dc8b2ae51 100644
--- a/net-nds/openldap/openldap-2.4.59-r1.ebuild
+++ b/net-nds/openldap/openldap-2.4.59-r1.ebuild
@@ -864,6 +864,8 @@ pkg_preinst() {
pkg_postinst() {
if ! use minimal ; then
+ tmpfiles_process slapd.conf
+
# You cannot build SSL certificates during src_install that will make
# binary packages containing your SSL key, which is both a security risk
# and a misconfiguration if multiple machines use the same key and cert.
diff --git a/net-nds/openldap/openldap-2.5.4.ebuild b/net-nds/openldap/openldap-2.5.4.ebuild
index c0fabfd506f8..8c6dab1cf306 100644
--- a/net-nds/openldap/openldap-2.5.4.ebuild
+++ b/net-nds/openldap/openldap-2.5.4.ebuild
@@ -796,6 +796,8 @@ pkg_preinst() {
pkg_postinst() {
if ! use minimal ; then
+ tmpfiles_process slapd.conf
+
# You cannot build SSL certificates during src_install that will make
# binary packages containing your SSL key, which is both a security risk
# and a misconfiguration if multiple machines use the same key and cert.