summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-15 04:22:48 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-15 04:32:03 -0800
commit7cb8559a91b2c1d8508b877e711ded939f0c0bef (patch)
tree24fbbf39fe0f76cd018a111d4acfabc70335d837 /net-nds
parentdev-util/boost-build: drop 1.76.0-r2 (diff)
downloadgentoo-7cb8559a91b2c1d8508b877e711ded939f0c0bef.tar.gz
gentoo-7cb8559a91b2c1d8508b877e711ded939f0c0bef.tar.bz2
gentoo-7cb8559a91b2c1d8508b877e711ded939f0c0bef.zip
net-nds/gssproxy: create /var/lib/gssproxy/rcache
without that directory present krb nfs mounts fail with very confusing and hard to debug messages. systemd unit sets Environment=KRB5RCACHEDIR=/var/lib/gssproxy/rcache but does not create it. Let's do it in ebuild and openrc service. Fedora's rpm spec also creates it mkdir -p %{buildroot}%{gpstatedir}/rcache https://src.fedoraproject.org/rpms/gssproxy/blob/rawhide/f/gssproxy.spec Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/gssproxy/files/gssproxy1
-rw-r--r--net-nds/gssproxy/gssproxy-0.8.4-r1.ebuild (renamed from net-nds/gssproxy/gssproxy-0.8.4.ebuild)3
2 files changed, 3 insertions, 1 deletions
diff --git a/net-nds/gssproxy/files/gssproxy b/net-nds/gssproxy/files/gssproxy
index 750e7623cdcc..34e4983b384f 100644
--- a/net-nds/gssproxy/files/gssproxy
+++ b/net-nds/gssproxy/files/gssproxy
@@ -12,4 +12,5 @@ depend() {
start_pre() {
checkpath -d -m 0755 /var/lib/gssproxy
+ checkpath -d -m 0755 /var/lib/gssproxy/rcache
}
diff --git a/net-nds/gssproxy/gssproxy-0.8.4.ebuild b/net-nds/gssproxy/gssproxy-0.8.4-r1.ebuild
index dd5999942c52..df211a14dbf6 100644
--- a/net-nds/gssproxy/gssproxy-0.8.4.ebuild
+++ b/net-nds/gssproxy/gssproxy-0.8.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -82,6 +82,7 @@ src_install() {
newins examples/mech gssproxy.conf
keepdir /var/lib/gssproxy
+ keepdir /var/lib/gssproxy/rcache
# The build installs a bunch of empty dirs, so prune them.
find "${ED}" -depth -type d -empty -delete || die