summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-10-09 18:56:15 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-10-09 18:57:05 +0300
commit873d3aabf93c8b03ac7a2fdd17ea73b39f838676 (patch)
treea24fe0eb36ad83f0f2d079bc83f97cc1e6b99c99 /net-nds
parentnet-analyzer/zabbix: removed obsolete 4.0.23 & 5.0.2 (diff)
downloadgentoo-873d3aabf93c8b03ac7a2fdd17ea73b39f838676.tar.gz
gentoo-873d3aabf93c8b03ac7a2fdd17ea73b39f838676.tar.bz2
gentoo-873d3aabf93c8b03ac7a2fdd17ea73b39f838676.zip
net-nds/openldap: Do not hardcode bash
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/openldap/openldap-2.4.50.ebuild6
-rw-r--r--net-nds/openldap/openldap-2.4.53.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/net-nds/openldap/openldap-2.4.50.ebuild b/net-nds/openldap/openldap-2.4.50.ebuild
index 71320172f0b0..2c5a8f5c18c4 100644
--- a/net-nds/openldap/openldap-2.4.50.ebuild
+++ b/net-nds/openldap/openldap-2.4.50.ebuild
@@ -514,7 +514,7 @@ multilib_src_configure() {
done
tc-export AR CC CXX
- CONFIG_SHELL="/bin/bash" \
+ CONFIG_SHELL="/bin/sh" \
ECONF_SOURCE="${S}" \
STRIP=/bin/true \
econf \
@@ -548,7 +548,7 @@ src_configure_cxx() {
multilib_src_compile() {
tc-export AR CC CXX
- emake CC="${CC}" AR="${AR}" SHELL="${EPREFIX}"/bin/bash
+ emake CC="${CC}" AR="${AR}" SHELL="${EPREFIX}"/bin/sh
local lt="${BUILD_DIR}/libtool"
export echo="echo"
@@ -730,7 +730,7 @@ multilib_src_test() {
multilib_src_install() {
local lt="${BUILD_DIR}/libtool"
- emake DESTDIR="${D}" SHELL="${EPREFIX}"/bin/bash install
+ emake DESTDIR="${D}" SHELL="${EPREFIX}"/bin/sh install
if ! use minimal && multilib_is_native_abi; then
# openldap modules go here
diff --git a/net-nds/openldap/openldap-2.4.53.ebuild b/net-nds/openldap/openldap-2.4.53.ebuild
index 89a4da0e8209..759f15457765 100644
--- a/net-nds/openldap/openldap-2.4.53.ebuild
+++ b/net-nds/openldap/openldap-2.4.53.ebuild
@@ -514,7 +514,7 @@ multilib_src_configure() {
done
tc-export AR CC CXX
- CONFIG_SHELL="/bin/bash" \
+ CONFIG_SHELL="/bin/sh" \
ECONF_SOURCE="${S}" \
STRIP=/bin/true \
econf \
@@ -548,7 +548,7 @@ src_configure_cxx() {
multilib_src_compile() {
tc-export AR CC CXX
- emake CC="${CC}" AR="${AR}" SHELL="${EPREFIX}"/bin/bash
+ emake CC="${CC}" AR="${AR}" SHELL="${EPREFIX}"/bin/sh
local lt="${BUILD_DIR}/libtool"
export echo="echo"
@@ -730,7 +730,7 @@ multilib_src_test() {
multilib_src_install() {
local lt="${BUILD_DIR}/libtool"
- emake DESTDIR="${D}" SHELL="${EPREFIX}"/bin/bash install
+ emake DESTDIR="${D}" SHELL="${EPREFIX}"/bin/sh install
if ! use minimal && multilib_is_native_abi; then
# openldap modules go here