summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-06-05 23:53:44 -0400
committerMike Frysinger <vapier@gentoo.org>2016-06-05 23:54:45 -0400
commitaf0ed32d2491eb16b4fd6f7083f9ce4c5651f766 (patch)
tree64bb8fe00081d138c030fb6d20b89324b23e16fd /net-nds
parentdev-libs/ding-libs: version bump to 0.5.0 #548208 (diff)
downloadgentoo-af0ed32d2491eb16b4fd6f7083f9ce4c5651f766.tar.gz
gentoo-af0ed32d2491eb16b4fd6f7083f9ce4c5651f766.tar.bz2
gentoo-af0ed32d2491eb16b4fd6f7083f9ce4c5651f766.zip
net-nds/gss-proxy: initial package #548208
Needed by newer nfs-utils for kerberos/nfsv4 services.
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/gss-proxy/Manifest1
-rwxr-xr-xnet-nds/gss-proxy/files/gssproxy15
-rw-r--r--net-nds/gss-proxy/gss-proxy-0.5.0.ebuild50
-rw-r--r--net-nds/gss-proxy/metadata.xml7
4 files changed, 73 insertions, 0 deletions
diff --git a/net-nds/gss-proxy/Manifest b/net-nds/gss-proxy/Manifest
new file mode 100644
index 000000000000..00e357a45134
--- /dev/null
+++ b/net-nds/gss-proxy/Manifest
@@ -0,0 +1 @@
+DIST gssproxy-0.5.0.tar.gz 526047 SHA256 0965448e145b0d764ba5ca7707a7bf3d2c9d555f96fcb3ba0d88673a233b31d6 SHA512 14a50583fa304a667243b470415d107026042871374b69e5c5ff82ceb7ae9fd83532241ac032e79e87cea1706970ea0d552f5fc31a0340e22242f4cc4abd5cf8 WHIRLPOOL 9352644e76ba96a0c36640d0cc703f74b5ba48f980edb668f1c98efedab5e9d16c094080af950ba94cf9ceac88bf10f3b68876e83942ae4cafb9d7ddd74ec486
diff --git a/net-nds/gss-proxy/files/gssproxy b/net-nds/gss-proxy/files/gssproxy
new file mode 100755
index 000000000000..8c29f899f2ca
--- /dev/null
+++ b/net-nds/gss-proxy/files/gssproxy
@@ -0,0 +1,15 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command="gssproxy"
+command_args="-D"
+pidfile="/var/run/gssproxy.pid"
+
+depend() {
+ use logger
+}
+
+start_pre() {
+ checkpath -d -m 0755 /var/lib/gssproxy
+}
diff --git a/net-nds/gss-proxy/gss-proxy-0.5.0.ebuild b/net-nds/gss-proxy/gss-proxy-0.5.0.ebuild
new file mode 100644
index 000000000000..a45a5f0c5f8d
--- /dev/null
+++ b/net-nds/gss-proxy/gss-proxy-0.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+MY_P="${PN/-}-${PV}"
+
+DESCRIPTION="daemon to proxy GSSAPI context establishment and channel handling"
+HOMEPAGE="https://fedorahosted.org/gss-proxy/"
+SRC_URI="https://fedorahosted.org/released/gss-proxy/${MY_P}.tar.gz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug selinux systemd"
+
+RDEPEND=">=dev-libs/libverto-0.2.2
+ >=dev-libs/ding-libs-0.5.0
+ virtual/krb5
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # The build assumes localstatedir is /var and takes care of
+ # using all the right subdirs itself.
+ econf \
+ --localstatedir="${EPREFIX}/var" \
+ --with-os=gentoo \
+ --with-initscript=$(usex systemd systemd sysv) \
+ $(use_with selinux) \
+ $(use_with debug gssidebug)
+}
+
+src_install() {
+ default
+ # This is a plugin module, so no need for la file.
+ find "${ED}"/usr -name proxymech.la -delete
+
+ doinitd "${FILESDIR}"/gssproxy
+ insinto /etc/gssproxy
+ doins examples/*.conf
+ insinto /etc/gss/mech.d
+ newins examples/mech gssproxy.conf
+
+ # The build installs a bunch of empty dirs, so prune them.
+ find "${ED}" -depth -type d -exec rmdir {} + 2>/dev/null
+}
diff --git a/net-nds/gss-proxy/metadata.xml b/net-nds/gss-proxy/metadata.xml
new file mode 100644
index 000000000000..aebca33be179
--- /dev/null
+++ b/net-nds/gss-proxy/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>base-system@gentoo.org</email>
+</maintainer>
+</pkgmetadata>