summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2017-11-04 16:35:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-30 00:19:20 +0100
commit6870bf78eaa617688f718773e5181d42ae05f5f5 (patch)
tree68fc2a1e56dc3cd4ae6cf80c54e81eae274b1d1c /net-news/rssguard/rssguard-3.5.5.ebuild
parentnet-news/rssguard: update live version (diff)
downloadgentoo-6870bf78eaa617688f718773e5181d42ae05f5f5.tar.gz
gentoo-6870bf78eaa617688f718773e5181d42ae05f5f5.tar.bz2
gentoo-6870bf78eaa617688f718773e5181d42ae05f5f5.zip
net-news/rssguard: version bump to 3.5.5
Diffstat (limited to 'net-news/rssguard/rssguard-3.5.5.ebuild')
-rw-r--r--net-news/rssguard/rssguard-3.5.5.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-news/rssguard/rssguard-3.5.5.ebuild b/net-news/rssguard/rssguard-3.5.5.ebuild
new file mode 100644
index 000000000000..ce581c458621
--- /dev/null
+++ b/net-news/rssguard/rssguard-3.5.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic qmake-utils
+
+DESCRIPTION="A tiny RSS and Atom feed reader"
+HOMEPAGE="https://github.com/martinrotter/rssguard"
+SRC_URI="https://github.com/martinrotter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug webengine"
+MINQT="5.8:5"
+
+RDEPEND="
+ >=dev-qt/qtcore-${MINQT}
+ >=dev-qt/qtgui-${MINQT}
+ >=dev-qt/qtnetwork-${MINQT}
+ >=dev-qt/qtsql-${MINQT}
+ >=dev-qt/qtwidgets-${MINQT}
+ >=dev-qt/qtxml-${MINQT}
+ webengine? ( >=dev-qt/qtwebengine-${MINQT}[widgets] )
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/linguist-tools-${MINQT}
+"
+
+src_configure() {
+ # needed after 8eb640b6f2e140e7c5a1adbe5532cf3662d850b5
+ "$(qt5_get_bindir)/lrelease" rssguard.pro || die "lrelease failed"
+ # CONFIG+=ltcg is needed because of https://github.com/martinrotter/rssguard/issues/156
+ eqmake5 \
+ CONFIG+=$(usex debug debug release) \
+ $(is-flagq -flto* && echo "CONFIG+=ltcg") \
+ USE_WEBENGINE=$(usex webengine true false) \
+ LRELEASE_EXECUTABLE="$(qt5_get_bindir)/lrelease" \
+ PREFIX="${EPREFIX}"/usr \
+ INSTALL_ROOT=.
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}