summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-news/yarssr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-news/yarssr')
-rw-r--r--net-news/yarssr/Manifest1
-rw-r--r--net-news/yarssr/files/yarssr-0.2.2-code_injection_197660.patch12
-rw-r--r--net-news/yarssr/files/yarssr-0.2.2-cve-2007-5837.patch23
-rw-r--r--net-news/yarssr/files/yarssr-0.2.2-makefile.patch16
-rw-r--r--net-news/yarssr/metadata.xml8
-rw-r--r--net-news/yarssr/yarssr-0.2.2-r2.ebuild30
6 files changed, 90 insertions, 0 deletions
diff --git a/net-news/yarssr/Manifest b/net-news/yarssr/Manifest
new file mode 100644
index 000000000000..f13974a24fb1
--- /dev/null
+++ b/net-news/yarssr/Manifest
@@ -0,0 +1 @@
+DIST yarssr-0.2.2.tar.bz2 19567 SHA256 8f9a015a0e97f913edb93b5b9f89c34cac5783fc3cdbec32f9bb7cbda63c8a58 SHA512 ae9fcac6027776dd89af618273a03ed58260e69458681cd694af0a2f087f7595543af46c303184fb1d973efd3cb06a798b5d6e771f633faf53928e2c1dad412c WHIRLPOOL 27ce22e2c85fa2bcfda12cd7e682c76fda419765a695c742f199236e171a4089e7f27625520b5e6ddac2d96592810d551972afe0db30ffb8de7ed797800d0eaa
diff --git a/net-news/yarssr/files/yarssr-0.2.2-code_injection_197660.patch b/net-news/yarssr/files/yarssr-0.2.2-code_injection_197660.patch
new file mode 100644
index 000000000000..4f5b11130f6f
--- /dev/null
+++ b/net-news/yarssr/files/yarssr-0.2.2-code_injection_197660.patch
@@ -0,0 +1,12 @@
+diff -urNad yarssr-0.2.2~/lib/Yarssr/GUI.pm yarssr-0.2.2/lib/Yarssr/GUI.pm
+--- yarssr-0.2.2~/lib/Yarssr/GUI.pm 2007-10-31 12:40:08.000000000 +0100
++++ yarssr-0.2.2/lib/Yarssr/GUI.pm 2007-10-31 12:42:17.958217449 +0100
+@@ -164,7 +164,7 @@
+ else {
+ my $b = Yarssr::Config->get_browser;
+ $b .= " \"$url\"" unless $b =~ s/\%s/"$url"/;
+- exec($b) or warn "unable to launch browser\n";
++ exec(split(' ',$b)) or warn "unable to launch browser\n";
+ exit;
+ }
+ }
diff --git a/net-news/yarssr/files/yarssr-0.2.2-cve-2007-5837.patch b/net-news/yarssr/files/yarssr-0.2.2-cve-2007-5837.patch
new file mode 100644
index 000000000000..a73289d98d66
--- /dev/null
+++ b/net-news/yarssr/files/yarssr-0.2.2-cve-2007-5837.patch
@@ -0,0 +1,23 @@
+Improved patch to fix CVE 2007-5837 - remote code injection.
+See Gentoo bug #197660 and #378413.
+
+--- yarssr-0.2.2/lib/Yarssr/GUI.pm
++++ yarssr-0.2.2/lib/Yarssr/GUI.pm
+@@ -163,8 +163,15 @@
+ }
+ else {
+ my $b = Yarssr::Config->get_browser;
+- $b .= " \"$url\"" unless $b =~ s/\%s/"$url"/;
+- exec($b) or warn "unable to launch browser\n";
++ my @b = split(' ', Yarssr::Config->get_browser);
++ if (grep(/\%s/, @b))
++ {
++ map {grep(s/\%s/$url/, $_) => $_} @b;
++ }
++ else {
++ push(@b, $url);
++ }
++ exec(@b) or warn "unable to launch browser\n";
+ exit;
+ }
+ }
diff --git a/net-news/yarssr/files/yarssr-0.2.2-makefile.patch b/net-news/yarssr/files/yarssr-0.2.2-makefile.patch
new file mode 100644
index 000000000000..70655550955e
--- /dev/null
+++ b/net-news/yarssr/files/yarssr-0.2.2-makefile.patch
@@ -0,0 +1,16 @@
+--- Makefile.orig 2006-10-24 22:01:58.000000000 -0600
++++ Makefile 2006-10-24 22:02:16.000000000 -0600
+@@ -1,4 +1,4 @@
+-PREFIX=/usr/local
++PREFIX=/usr
+ BINDIR=$(PREFIX)/bin
+ LIBDIR=$(PREFIX)/lib/yarssr
+ DATADIR=$(PREFIX)/share
+@@ -27,7 +27,6 @@
+ @echo Copying share files to $(DESTDIR)/$(DATADIR):
+ @cp -Rp share/* $(DESTDIR)/$(DATADIR)/
+
+- find $(DESTDIR)/$(DATADIR) -type f -exec chmod 644 "{}" \;
+ find $(DESTDIR)/$(LIBDIR) -type f -exec chmod 644 "{}" \;
+
+ install -m 0644 build/locale/en/$(LC_CATEGORY)/yarssr.mo $(DESTDIR)/$(LOCALEDIR)/en/$(LC_CATEGORY)/
diff --git a/net-news/yarssr/metadata.xml b/net-news/yarssr/metadata.xml
new file mode 100644
index 000000000000..2b1cff497109
--- /dev/null
+++ b/net-news/yarssr/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-news</herd>
+ <upstream>
+ <remote-id type="sourceforge">yarssr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-news/yarssr/yarssr-0.2.2-r2.ebuild b/net-news/yarssr/yarssr-0.2.2-r2.ebuild
new file mode 100644
index 000000000000..6412f59291a5
--- /dev/null
+++ b/net-news/yarssr/yarssr-0.2.2-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Yet Another RSS Reader - A KDE/Gnome system tray rss aggregator"
+HOMEPAGE="http://yarssr.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/Locale-gettext
+ dev-perl/XML-RSS
+ dev-perl/gtk2-trayicon
+ dev-perl/gtk2-gladexml
+ dev-perl/gnome2-vfs-perl
+ >=dev-perl/gnome2-perl-0.94"
+
+DOCS=( ChangeLog TODO README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-cve-2007-5837.patch
+}